Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed Fedora 18 x86_64bit version in dual boot mode on my HP Envy 4 1002tx machine and whenever I log into the Gnome shell I am facing very sever overheating of my laptop base and the there is a very loud sound like a very fast moving fan coming from the laptop.

Full specs of my laptop can be found at: http://h10025.www1.hp.com/ewfrf/wc/document?cc=us&lc=en&dlc=en&docname=c03342406

This only happens when I am booting using the new Gnome graphics mode. If I boot into the just the command line interface or into the downgraded Gnome interface the laptop heating issue are not experienced.

My laptop has AMD Radeon HD 7670M (2 GB DDR3 dedicated) graphics card and I have never faced any issue of overheating in my windows 8 installation. Other important configurations are: Microprocessor 1.7 GHz Intel Core i5-3317U Microprocessor Cache 3 MB L3 cache Memory 4 GB 1600 MHz DDR3

Because of the overheating I am also facing a very low battery life and it sustains only for 2 hours as opposed to the 5-6 hours in general.

I also tried installing the ATI radeon drivers using all the various methods like: 1. kmod-catalyst 2. akmod-catalyst 3. Official driver for linux from ATI site.

In all cases I ran into config issues which could only be resolved after deleting the Xorg.conf file.

After using all the 3 approaches above on rebooting I lost the gnome shell and my system will not bring up gnome. After deleting the xorg.conf I was able to get into gnome but was only presented with the downgraded version of gnome in which the system settings feature stopped working.

I like the gnome 3.6.2 interface and would want to stick to it that is why I am still running my laptop in Fedora irrespective of the overheating issue.

Looking forward to a solution or advice on how to solve this problem.

share|improve this question
    
I suspect you have both a hardware issue and a software issue. The software issue is causing the CPU or GPU to do more work than it should and the hardware issue is causing the laptop to poorly handle the extra heat generated. (The hardware problem may be excessive dust that's easily removed with compressed air.) –  David Schwartz Feb 2 '13 at 22:47
    
Hi @DavidSchwartz I don't think the problem is of hardware as my laptop is just 3 months old. I have heard that GNOME new version takes a lot of CPU and that might be causing problems. –  Shubhanshu Mishra Feb 3 '13 at 7:21
    
@ShubhanshuMishra Because hardware problems only manifest after a well defined period of time, right? –  ta.speot.is Feb 3 '13 at 8:32

1 Answer 1

The issue has been resolved by installing the Gnome Shell Extension - Radeon Power Profile Manager and selecting Set profile to "low" option in it.

More details can be found at: http://smexyyweby.wordpress.com/2013/02/03/resolve-overheating-issue-for-amd-radeon-graphics-card-for-gnome-3-6-in-fedora-18/

share|improve this answer
    
Year of Linux on the Desktop, I say. –  ta.speot.is Feb 3 '13 at 8:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.