Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The problem

I have this DNS problem once per day, where I can't navigate to any website on any browser but the already started downloads or media streaming continue to run fine.

cmd ipconfig /all

While the issue lasts:

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Home
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : lan

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : lan
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 50-E5-49-55-86-0C
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.1.64(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Saturday, February 02, 2013 5:37:39 AM
   Lease Expires . . . . . . . . . . : Sunday, February 03, 2013 5:37:39 PM
   Default Gateway . . . . . . . . . : 192.168.1.254
   DHCP Server . . . . . . . . . . . : 192.168.1.254
   DNS Servers . . . . . . . . . . . : 192.168.1.254
   NetBIOS over Tcpip. . . . . . . . : Enabled

Just after the issue disappears:

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Home
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : lan

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : lan
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 50-E5-49-55-86-0C
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.1.64(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Saturday, February 02, 2013 5:37:39 AM
   Lease Expires . . . . . . . . . . : Sunday, February 03, 2013 10:52:52 PM
   Default Gateway . . . . . . . . . : 192.168.1.254
   DHCP Server . . . . . . . . . . . : 192.168.1.254
   DNS Servers . . . . . . . . . . . : 192.168.1.254
   NetBIOS over Tcpip. . . . . . . . : Enabled

What solves it

Restarting the router/windows or just waiting for 5-10 min. But the issue re-appears next day.

What doesn't solve it

Any of the following: cmd commands I tried like /flushdns or /renew, disabling windows firewall or disabling IPv6.

Edit

  • Router: Speedtouch 510 (5.4.0.14)
  • ISP: LINKdotNET (Egypt)
  • Wired DSL connection

Any help with this ?

share|improve this question
    
It looks like your router/gateway is handling all the DNS? Usually your ISP's DNS servers are also used. Can you provide more information about your network setup? –  iglvzx Feb 3 '13 at 7:17
    
I'm no expert, but have you considered switching to the Goole DNS servers (8.8.8.8 and 8.8.4.4)? –  Marcus Chan Feb 3 '13 at 7:18
    
@iglvzx Do you mean something like a cmd command ? because I have no idea :) MarcusChan yes, it is the same problem. –  Red John Feb 3 '13 at 7:22
    
@RedJohn No. I am asking about how your network is actually setup, e.g. what router model, who your ISP is, etc. –  iglvzx Feb 3 '13 at 7:30
    
@iglvzx I've updated the post. –  Red John Feb 3 '13 at 7:41

3 Answers 3

Try using a public DNS server. Use namebench to find the fastest resolvers.

share|improve this answer
    
I've used a similar tool, it shows that my local ISP servers is the fastest ones I could use. –  Red John Feb 3 '13 at 8:40

It appears as though your ISP might be rebooting their DNS servers. I would use a different set of DNS servers (like Google's or OpenDNS's) even though they might be slower, at least they're always up.

What you could do is have your ISP's DNS as the primary and Google's as the secondary. That way when your ISP's DNS servers stop responding you can still DNS results.

share|improve this answer
    
I think the OP said he'd already tried Google DNS and had the same issue, but I may be wrong on that. –  Marcus Chan Feb 4 '13 at 8:07

I had a similar problem long time ago in windows XP. everything was working but browsing.

Once you discard the DNS as the source of the problem try to uninstall/reinstall the "client for microsoft networks" in cmd>ncpa.cpl>connection properties.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.