Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using a DHCPv6 server (Dnsmasq) to assign IPv6 address in my LAN. My configuration works, but I am unable to ping the DHCPv6 server. The route information on host machine does not contain a route to the DHCPv6 server. What are the default routes created by Win 7 host towards an IPv6 address. On what basis are these automatic routes created. What is the information required to create a route by the Win 7 host.

share|improve this question

1 Answer 1

The IPv6 routing table is usually based on the information in the IPv6 Router Advertisements (RAs) that a box received. RAs are part of the Neighbor Discovery RFC4861 standard. The RA contains a lifetime value for creating a default route. If the lifetime is larger than 0 the router sending the RA will be used as a default route.

There is also an extension to RA messages in RFC4191. With this extension an RA can also contain more specific routes, each with its own lifetime value.

The DHCPv6 server does not create or need extra routes. All routing is done through the normal routing table. The DHCPv6 server is a normal server and can be pinged like any other box, if your routing is set up properly of course.

share|improve this answer
    
Thanks Sander. I forgot to mention, my RA message have the 'M' bit set. So, the IPv6 address is provided by DHCPv6 and not autoconfigured from the prefix information from the RA message. How does this change the scheme for auto route addition? –  tecMav Feb 4 '13 at 6:48
    
No change at all: routing is still done based on the information in the RA. The only change if you enable the 'M' bit and disable the 'A' bit in the prefix is that you tell the host that it should not autogenerate an address but that it should ask the DHCPv6 server. If you don't include any prefixes in the RA then the host won't add interface routes for them. If you set the default gateway timeout to 0 then the host won't create a default route to the link-local address of the router that sent the RA. That will leave you pretty disconnected ;-) –  Sander Steffann Feb 4 '13 at 14:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.