Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Last year, I had no trouble with doing the following:

  • Create virtual machine
  • Set network adapter to bridged adapter
  • Set static IP
  • Guest connects to Internet, host connects to guest @ 192.168.1.xxx

Bought a SSD, reinstalled Win7, programs etc., cannot accomplish the same.

Scenario 1: bridged adapter + leave /etc/network/interfaces left as dhcp, I can ping out from guest.

Scenario 2: bridged adapter + /etc/network/interfaces set to static, host can connect to guest, but guest cannot see WWW.

This interfaces setting used to work for me:

  1. auto eth0
  2. iface eth0 inet static
  3. address 192.168.1.111
  4. netmask 255.255.255.0
  5. gateway 192.168.1.1 [or gateway 192.168.56.1]

from Vbox [not enough points for image]

  1. Host-only network details
  2. adapter
  3. IPv4 Address: 192.168.56.1
  4. IPv4 Network Mask: 255.255.255.0

Host network like:

  1. VirtualBox Host Only Network
  2. Unidentified Network
  3. VirtualBox Host Only Network Adapter

Wireless Network Connection
myWifi
Belkin USB Wireless Adapter

I have tried abandoning the bridged adapter for NAT+Host only as I've seen in several posts like this one, but the results are the same.

Thanks for your suggestions.

share|improve this question
up vote 1 down vote accepted

Use your scenario 2 and add in virtual box as a second adapter NAT, this should work

share|improve this answer
    
I use 1. network adapter NAT, 2nd adapter bridged and in /etc/network/interfaces auto eth1 iface eth1 inet static address 192.168.1.111 netmask 255.255.255.0 – Vojtana Jul 28 '15 at 12:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .