Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Installing windows XP Professional 64 bit on a virtual machine using VMware Workstation V9

When installing Windows XP by using the IMG file I have of the XP Installation disk mounted as a CD disk.

xp cannot find hard-disk

There are numerous articles covering this, but no apparent consensus on what exactly should be done to solve it. Many of the googled answers point to XP's flaky SCSI support and recommend the installation of SCSI drivers through the mounting of a floppy image (http://download3.vmware.com/software/vmscsi-1.2.0.4.flp). This didn't work for me, despite getting Windows xp to recognise the image. Upon getting a confirmation of the install and an installation welcome screen, the exact same hard-disk error displayed, preventing any further progress.

scsi driver install xp

Some guides discussing the problem mention how this may not always work and a somewhat home-brewed patch may be required. Other sources have stated that a LSILogic Driver may be required. Other guides such as this, despite being very detailed, give distinctly incorrect advice (in particular, suggesting that using an earlier version of Workstation or choosing IDE over SCSI as an install parameter (if the machine does not support such) will overcome this problem.

I have been, if anything, left more confused. :/

NOTE: Windows XP installs fine on quick install, it is merely on custom installation that this error is triggered.

share|improve this question
    
not need vmware scsi driver ... wait 2 hour I test it) –  STTR Feb 3 '13 at 18:44
add comment

1 Answer

up vote 2 down vote accepted

Vmware 9 Windows XP 64 VM

not need add driver.

Vmware 9 Windows XP 64 VM

CD: AMD64\eula.txt

EULAID:WS03SP1_RM.0_PX64_RTL_EN

remove not need device

device settings

setup SCSI HDD VMWare

SCSI HDD VMWare

Set Microsoft Windows 64

Windows XP Professional x64 Edition.vmx:

guestOS = "winxppro-64"

Set Microsoft Windows 64

share|improve this answer
    
Hi. Thanks for the reply, but I'm finding it slightly hard to follow. Is there something other than the driver that I need to do? –  Duncan Feb 3 '13 at 20:10
    
Select Windows XP 64. I add it in my answer + 10 min. –  STTR Feb 3 '13 at 20:13
    
if need add VM template file + winnt.sif –  STTR Feb 3 '13 at 20:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.