Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using windows 7 client and the latest version of ubuntu server installed inside vmware workstation.

Ubuntu server is a fresh install with just openssh server as the only program I installed in it via apt get so far.

I would like to get access to the Ubuntu server file system through a mapped drive on windows. When I go to Computer >> Map Network Drive and enter:

\\192.168.163.129\home\tk

It errors out saying windows cannot access: \\192.168.163.129\home\tk.

Is there anything I have to install to make this possible?

share|improve this question
add comment

2 Answers 2

You'll probably want samba not samba4, but it should work fine anyway; run 'smbpasswd -a USERNAME' and enter a password for your user. Samba keeps it's own password store that can be synced with the linux password (and last I checked the default in ubuntu is to turn on syncing) but you have to set the initial password with 'smbpasswd -a'.

Also, edit /etc/samba/smb.conf and uncomment the homes section (should be near the bottom). Leave the other settings to default.

It should look something like:

[home] browseable = no valid user = %s

(that is off the top of my head; probably best to not just copy paste in to your config, but those are the 2 directives samba will usually need for homes)

share|improve this answer
add comment

You could look into using Samba. I haven't set it up myself, but I know that it implements the same protocol that Windows normally uses to communicate with network drives. Ubuntu 12.04 has it as a package under the name samba, so just run sudo apt-get install samba.

share|improve this answer
    
I install samba4 on the server and tried to map the network drive again and got the same error. Did I have to do anything else after installing samba? –  JakeRow123 Feb 3 '13 at 22:23
    
so after install samba not samba4 I do get a password prompt. But when I type my password which is correct it says network password is incorrect. –  JakeRow123 Feb 3 '13 at 22:34
    
Try this: serverfault.com/questions/91797/… –  cpast Feb 3 '13 at 22:36
    
Those fixes listed are not relevant on an recent version of samba. You shouldn't need to change anything on the windows side, source: i'm running samba 3 and 4 against windows 7/8 clients and they still work fine after slowly upgrading from xp->vista->onwards –  Justin Feb 3 '13 at 22:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.