Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How to make Task Manager run automatically when Windows 8 starts?

share|improve this question

migrated from Feb 4 '13 at 3:27

This question came from our site for professional and enthusiast programmers.

4 Answers 4

you must use the task scheduler approach to start the task scheduler. This is required, because the new Taskmgr requires admin rights to start (because of ETW which is used for network and IO data). Create the schtasks.exe shortcut and place this shortcut into the known startup locations.

share|improve this answer

I usually start the Taskmanager with

start /min taskmgr.exe

In Windows 7 this worked perfectly. Together with the option "hide when minimized" tis resultet in only the tray icon visible after startup.

In Windows 8 however the option "hide when minimized" didn't work anymore and the task manager was also shown in the taskbar.

This can be corrected using NirCmd ( command to start the task manager

nircmd.exe exec hide taskmgr

This command needs administrator privileges to run

share|improve this answer

Here is the way I automatically start Task Manager in Windows 8.1. Like Christian Meister's answer I want to start it minimized but in addition want Hide when Minimized to work correctly:

My solution is to create a task in Task Scheduler with:

  • Trigger on user login
  • Run with highest privileges

and then add two actions to it:

  • nircmd exec show taskmgr
  • nircmd cmdwait 2000 win min ititle "<taskmgr window title in your language>"

First time you run it you have to set up your desired options and positions and then it should work correctly in the future. The separate minimize command is needed as Task Manager in Win 8.1 seems not to honour Hide when Minimized when started minimized.

It would be possible to create a separate shortcut file to the scheduled task like in magicandre1981's answer but personally I prefer to minimize the number of moving parts (and I haven't found a native way to do what nircmd does in this solution).

share|improve this answer

First, start Task Manager manually (Start, taskmgr, Enter) and enable Options -> Hide when minimized.

Then, in Windows Explorer, open following folder:

C:\Users\<username>\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup

If you want this to be active for all users, open this folder instead:

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup

Now, right click on empty space, select New -> Shortcut. Type in taskmgr, click OK and Finish.

You are not done yet! Right click on new taskmgr shortcut, select Properties. Now, in Shortcut tab, configure Run -> Minimized.

Now, reboot. After you switch to desktop again, make sure you configure Control Panel -> Notification Area Icons such that Windows Task Manager is set to Show icon and notifications (default setting is Only show notifications).

share|improve this answer
This did not work for me. – Richard Everett Aug 16 '13 at 9:24
@RichardEv: how do you know that it did not? Note that Task Manager in this recipe is started minimized. You are not likely to see that it is running if you start in Win8 Start screen. If you launch Desktop, you should see small TaskManager green/yellow icon running in tray bar, next to clock. – mvp Aug 16 '13 at 9:32
I know because I tried both options, as you describe. – Richard Everett Aug 16 '13 at 10:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.