Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just followed a tutorial on how to customize icons in Windows 8 (see link below). However, when I open the program, it shows the default icon in the taskbar and not the changed icon. How do I get the program to stay open in the custom icon, not in the default icon? Interestingly, the custom icon for Chrome browser is the only thing that works. The other custom icons, WMP and iTunes, doesn't work. I wonder why?

Tutorial: Customize Your Icons in Windows 7 and Vista

1

share|improve this question
1  
Have you tried to rebuild the icon cache? –  nixda Feb 4 '13 at 7:11
    
@nixda: See my edited post above. –  IronFalcon Feb 16 '13 at 7:01
    
Glad to see you solved it. Can you please post your solution as a separate answer (and mark it as accepted later) ? This is the preferred way on SU :) –  nixda Feb 16 '13 at 8:00
    
@nixda: Already did it. Thanks for letting me know. :) –  IronFalcon Feb 17 '13 at 7:52

3 Answers 3

Rebuild the icon cache as recommended above. If that doesn't help, try the following. While I don't have WMP or iTunes to test this with, it has worked with every other program I have tested with:

  1. Right-click the Desktop and create a new shortcut to the program's EXE

  2. Right-click the shortcut, click on Properties and Change the Icon

  3. Right-click the shortcut and Pin it to the Taskbar (once you do this, you can delete the original shortcut on the Desktop)

  4. Most important: Right-click the taskbar, click on Properties and select Always combine, hide labels:

    1

  5. Now you can click the new icon to run the program, and the icon should persist (which it doesn't seem to do when bigger taskbar buttons with labels are displayed)

share|improve this answer
    
Are you sure you had Always combine turned on and you created brand new shortcuts? If it still did not work, then those two programs in particular must be overriding the custom icon specified when they're executed (like I said, everything I tested worked just fine, but I don't use those two). As cbabb mentioned, nothing you can likely do about that besides messing with the EXE's embedded icon resources, which I wouldn't really recommend. –  Karan Feb 7 '13 at 22:11
    
After more than a week of trial and error, I have finally figured out a solution to this pesky problem! Actually, there are two solutions because one of them does not work for the other and vice versa. See my edited post with the included instructions above. By the way, I did follow your suggestions (yes, I had Always combine turned on) and both did not work. The solution I've discovered is the only one that works. –  IronFalcon Feb 16 '13 at 6:59
    
@IronFalcon: You should edit your solutions out and add them as a separate answer. Self-answering is encouraged here. –  Karan Feb 16 '13 at 14:40
up vote 0 down vote accepted

Solution for iTunes icon:

  1. Right-click the iTunes icon and click Pin to Taskbar.

  2. Click on it to launch iTunes. Note that clicking on it will cause iTunes to open a duplicate icon on the taskbar.

  3. Right-click the duplicate icon and pin it to taskbar.

  4. Right-click the original icon and unpin it. Make sure when you click on the duplicate one you just pinned, that it opens iTunes and doesn't open another duplicate icon. If it does, try the steps again.

  5. Right-click the new icon, and then right-click on where it says iTunes (2) in the jumplist and click Properties to launch device's properties window. Note that the number 2 enclosed by parentheses was created automatically when you pinned the duplicate icon to taskbar.

  6. In the window that opens, click on the Change Icon under the Shortcut tab.

  7. Click Browse and choose the icon you want to use from the location you have it on your PC and click Open to import it.

  8. After choosing your icon, go to the General tab and rename iTunes (2) to just iTunes.

  9. Click OK to exit the iTunes Properties window.

  10. The default icon still hasn't changed, but if you open the jumplist by right-clicking the icon, you'll notice that the default icon has been replaced with a custom icon. The changed icon in the jumplist is due to renaming a file outlined in Step 8. Now in order to reflect the change on the taskbar, with the jumplist still open, click Properties again to launch device's properties window.

  11. Click on the Change Icon under the Shortcut tab.

  12. Unless you want to change to a different icon, click OK to exit the Change Icon window.

  13. Click OK again to exit the iTunes Properties window. Voila! You now have the custom icon you've always wanted. Although this solution works for iTunes, it will not work for WMP. Fortunately, I came up with a solution that worked for WMP. Here's how I did it.

Solution for WMP icon:

  1. Right-click the WMP icon and click Pin to Taskbar (skip this step if WMP is already pinned to taskbar).

  2. Click on it to launch WMP.

  3. Right-click the icon and unpin it.

  4. Right-click again on where it says Windows Media Player in the jumplist and click Properties to launch device's properties window.

  5. In the window that opens, click on the Change Icon under the Shortcut tab.

  6. Click Browse and choose the icon you want to use from the location you have it on your PC and click Open to import it.

  7. Click OK to exit the WMP Properties window.

  8. After clicking OK, you'll get a Access Denied message that states, "You will need to provide administrator permission to change these settings". Click continue to complete this operation. Note that the prompt message will not display if you turn off User Account Control (UAC).

  9. After exiting the properties window, the default icon will visibly change to custom icon. Right-click the icon and pin it to taskbar.

I hope my solutions works to any who find themselves in the same predicament.

share|improve this answer

Program icons are embedded within the .EXE file. You would have to change the resources inside the program in order to reflect that on the taskbar.

share|improve this answer
    
See my edited post above. –  IronFalcon Feb 16 '13 at 7:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.