Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a strange problem, where my mouse cursor vibrates at my home, but nowhere else. I've changed my mouse and reinstalled it's drivers.

However, when I unplug my mouse, the vibration stops and the laptop's touch-pad doesn't have this issue.

share|improve this question

migrated from stackoverflow.com Feb 4 '13 at 7:34

This question came from our site for professional and enthusiast programmers.

2  
Weird. So you're saying the only thing you've correlated with the vibration is your physical location? –  Marcus Chan Feb 4 '13 at 7:44
    
Do you have a mousepad at home, or are you using the mouse on a reflective surface? –  ta.speot.is Feb 4 '13 at 9:22
    
@MarcusChan yes –  Omid Kosari Feb 4 '13 at 10:10
    
@ta.speot.is as i said even the mouse pad is same . also i have changed it no success –  Omid Kosari Feb 4 '13 at 10:11
    
Does that happen in one spot or anywhere in your house? –  John Siu Feb 7 '13 at 3:07
show 9 more comments

8 Answers 8

All these seems unreal. Yesss, ghosts are vibrating your mouse =)

Maybe anything vibrates near the mouse. If not, and if nothing helped,
then simply try to boot to another OS.
It will help you to understand if the problem is in your OS or not.
If it continues to vibrate, then the problem is in your house.
Otherwise (if the problem is in your OS), run ProcMon.exe to watch what's happening when it vibrates, and also check autoruns (using Autoruns.exe, not msconfig), and check driver/program startup order with ProcExp.exe .You can download them in Sysinternals' website.

If after all this your mouse continues to vibrate... then ghosts are vibrating your mouse :)
Good Luck!

share|improve this answer
3  
Nice idea about booting another OS . i will try an ubuntu live and inform you . but i have already tried sysinternal tools . –  Omid Kosari Feb 8 '13 at 7:20
    
Bad news . the problem exists in Ubuntu , Gparted etc . also the problem exists in "Safe Mode" . –  Omid Kosari Feb 10 '13 at 17:04
    
Now you can be sure that it's not a driver/virus problem. The problem is not in your PC. The problem is in mouse or house :) fix your mouse. Also try another mouse. Or find vibrating things in your house! –  Jet Feb 11 '13 at 17:54
add comment

Clean.

First, make sure to clean your mouse optical hole thoroughly, ideally with lens cleanser and lint-free tissue. Different lighting conditions (day/night/fluorescent) between your work and home could cause different behaviors. Modern mouses are very sensitive and it's not always obvious it's a dusty/dirty problem until you clean it.

Known issues

What is your mouse model? Maybe there are known problems or device incompatibility with it.

Disable.

Next, I would try to disable EVERY "Mice and other pointing device" in Windows Device Manager. Maybe some unused device driver, or the touchpad itself could be interfering with your mouse.

Isolate the problem

Approach the issue scientifically. It's okay at work, bad at home.... surely, something is different between those 2 places! Try both battery or wall power. At home, try another room away from equipement. Try outside. In the park. Try half-way between your work and your home. Try at work in a meeting room. If it vibrates everywhere except your own work desk, ask your boss what he did to your mouse.

New: Corded vs wireless

Is this a wireless mouse anyway? Try a corded USB mouse. (Or vice-versa).

share|improve this answer
    
Already tried all of your ideas except trying half-way between work and home which is not good option . –  Omid Kosari Feb 7 '13 at 13:42
add comment

Possibly, there is a electromagnetic source close to the mouse (sometimes even mobile phone affects).

share|improve this answer
    
i have moved more than 20 meters away but problem still persists . –  Omid Kosari Feb 3 '13 at 20:00
    
also i moved every such devices away . i am happy that you got the point of view . –  Omid Kosari Feb 3 '13 at 20:12
add comment

Try to find the border where the behaviour changes. Does it jitter in the corridor? In front of your door? 20 meters away from the door?

Think about what else is different "at home": Wifi - turn if off. Power connection - unplug it. Direction of light - close drapes. Air conditioner or ventilator - turn off.

For further ideas, tell us which type of mouse you use. Did I understand correctly that other mice have the same problem? If possible, try another laptop, as well.

share|improve this answer
    
Thanks for good ideas . i tried every indoor places . also tried turning off the wifi by hardware key . also unplugged the power . another mouses on same laptop have same problem . this mouse on another laptop has no problem . another laptop works fine . –  Omid Kosari Feb 7 '13 at 9:00
add comment

Clean the mouse and the surface you're using it on. If it's wireless, try using a wired one. It may be RF interference.

share|improve this answer
add comment

Get a mouse pad, if you already have one get a new one.

Check to see if there are cracks or gaps on the surface on which you use the mouse. Try cleaning it.

It definitely has something to do with the surface because it has to be clean, level and flat.

share|improve this answer
add comment

The problem you are facing is really challenging. Your hardware is sensible to some interference with some signal that is present in your house. If you have a laptop, you could try and disconnect all the electrical stuff in your house, or even turn the electrical power off.

The signal could also come from outside, say a mobile communications antenna. It would also be worth trying with a cordless mouse. Maybe the mouse cable acts as an antenna.

I would add that since other laptops don't have the problem, your laptop's EM shielding is flawed. I would report that to the producer and ask for assistence.

share|improve this answer
    
Great answer.thanks –  Abadis Feb 12 '13 at 11:55
add comment

I have the exact same problem. Been out of town for a bout 10 days, it was fine. Now it's not. Nothing has changed. Not connected to the web, using wacom tablet. With or without tablet same problem. But good news, I just made it stop. Not sure what or why, cleaned the wacom mouse and pad, only TINY less vibration. But, when I moved the main computer mouse and adjusted what it was sitting on, it stopped. I think it's the computer mouse causing the trouble, not the wacom as it vibrated with the pen tool. Thanks for the suggestions. Now if I could just figure out why my cursor on my laptop jumps around the paragraph that would be even better. win 7, os. thanks

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.