Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows XP, and I installed Windows 7 to my D: partition. In Windows 7 I changed the timeout to 0 and default to 'Windows XP' from bcdedit. Now I can't see the OS selection at my startup. It always loads Windows XP. How can I solve this? Can I edit bcdedit.exe from Windows XP?

share|improve this question

4 Answers 4

You should be able to edit the BCD with EasyBCD.

It will let you change your boot order to whatever you like, but with a nice GUI around it.

alt text

share|improve this answer
1  
You know what, I'll upvote your answer ;-) –  Ivo Flipse Oct 13 '09 at 5:53
    
"Great minds think alike" :-) . Thanks! –  Snark Oct 13 '09 at 5:54
2  
I decided to delete mine and just add my things with yours, makes it easier to decide who to upvote ;-) –  Ivo Flipse Oct 13 '09 at 6:20

If EasyBCD doesn't work, insert the Windows 7 DVD and repair the bootloader. You can find out how to do that here.

share|improve this answer

Am I wrong? Can't you change these settings by going to msconfig? Or am I not understanding the question?

Go to run and type MSCONFIG and click on the boot tab. There you can change the boot timeout and default OS

share|improve this answer

You have no need to use any external software for setting up for default boot ..

Go to System properties -> Advance System Settings -> Startup & Recovery.

See the Screen of my OS. I have installed Win2k3 Server and Win7 on my laptop. enter image description here

just select your default OS that you want to start. and change the timeout time below this. you can use 5 or 10 seconds for this. may be enough to select an operating system to select from the list..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.