Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After rebooting from Windows XP to Gentoo Linux, I can't connect to anywhere (internet, others computers, router). Internet is working fine if instead of rebooting I shutdown the PC and then boot properly.

Ifconfig shows everything is fine, except no packet are received/transmitted.

ping 192.168.9.1
-> Destination Host Unreachable

mtr <ip> shows nothing, just empty line. Works only on loopback and IP specified in config: /etc/conf.d/net.eth0

IP is assigned automatically via DHCP and by MAC address (so both Linux & Windows have same IP)
IP is static 192.168.9.3.

Router used: Asus WL-500gP (with Oleg firmware), whole network is 100 Base-T, IP: 192.168.9.1 MASK: 255.255.255.0

Windows info:

  • NIC: Realtek RTL8139/810x Family
  • Driver version: 5.719.325.2009

Linux info:

  • DMESG: 8139too RealTek RTL8139
  • Kernel built-in driver: RealTek RTL-8129/8130/8139 PCI Fast Ethernet Adapter
  • Kernel version 3.5.7 & latest 3.7.4 (gentoo-sources)

The LEDs on NIC blink only in Windows, remain black even during POST.

share|improve this question
1  
ping? mtr? dig? What have you tried? Please be more specific than "No internet". –  Tom Wijsman Feb 4 '13 at 16:26
    
Tried pinging my router, from router to workstation, from another workstation etc.. I will update. –  A.D. Feb 4 '13 at 16:31
    
This may be a stupid question, but what happens if you bring the interface down and back up? Do you have the dhcp service enabled in Linux? –  nerdwaller Feb 4 '13 at 16:42
    
I tried it too. /etc/init.d/net.eth0 restart works, except sshd won't start. –  A.D. Feb 4 '13 at 16:44
    
@A.D.: If that fixes it, it sounds like a firmware / driver problem; dmesg might report about this. –  Tom Wijsman Feb 4 '13 at 16:48
show 2 more comments

2 Answers

up vote 2 down vote accepted

Google is my friend. Thanks goes to Ubuntu Forums and marvelous ArchWiki:

Users with Realtek 8168 8169 8101 8111(C) based NICs (cards / and on-board) may notice an issue where the NIC seems to be disabled on boot and has no Link light. This can usually be found on a dual boot system where Windows is also installed. It seems that using the offical Realtek drivers (dated anything after May 2007) under Windows is the cause. These newer drivers disable the Wake-On-LAN feature by disabling the NIC at Windows shutdown time, where it will remain disabled until the next time Windows boots. You will be able to notice if this issue is affecting you if the Link light remains off until Windows boots up; during Windows shutdown the Link light will switch off. Normal operation should be that the link light is always on as long as the system is on, even during POST. This issue will also affect other operative systems without newer drivers (eg. Live CDs).

Possible solutions:

  1. Rollback/change Windows driver
  2. Enable WOL in Windows driver
  3. Newer Realtek Linux driver
  4. Enable LAN Boot ROM in BIOS/CMOS

I tried 2nd one which works. 4th did not (MB is some old EPoX).

To Enable WOL hit WIN+R -> devmgmt.msc -> double-click your NIC -> On Advanced Tab set Shutdown Wake-On-Lan to Enabled. REBOOT!

enter image description here

If you are interested, bug is filled here: https://bugzilla.kernel.org/show_bug.cgi?id=53521

share|improve this answer
    
@TomWijsman I'll file this bug tomorrow. –  A.D. Feb 4 '13 at 22:16
add comment

What kernel version are you using? I'd try using the latest stable point release of the Linux kernel, at the very least.

My initial insight into this is that it's likely a bug where Windows "does something" to the hardware, which is not properly reset on a regular reboot, but is reset during a full power off. Whatever Windows does is incompatible with the way the 8139too driver works.

Using the latest kernel version will reduce the possibility that there is a bug which has already been fixed. If the latest kernel version doesn't resolve the bug, I would include the following in an email to LKML (the Linux Kernel Mailing List) or at least to the Gentoo developers:

  • Output of lspci -nnvv
  • Output of dmesg on a cold boot where ethernet works
  • Output of dmesg on a reboot from Windows
share|improve this answer
    
Yes, I have to discover what does that. What version of kernel "is" latest? I'm using 3.5.7. –  A.D. Feb 4 '13 at 16:42
    
@A.D.: 3.5.7 is latest Gentoo x86 stable, 3.6.11 is latest Gentoo AMD64 stable, 3.7.4 is latest Gentoo unstable; 3.7.6 is is latest upstream stable, 3.8-rc6 is mainline and can be considered the latest upstream unstable. I would suggest you to try =sys-kernel/gentoo-sources-3.7.4 as well as trying out the latest sys-kernel/git-sources. I don't see a relevant fix in the logs; so, if you still experience this please try to capture the information requested here and file it at bugs.gentoo.org. I'm doing bug wrangling as well as kernel bug wrangling there and will follow up on you... :) –  Tom Wijsman Feb 4 '13 at 16:45
    
@TomWijsman will try. I'll google for now, because it must be something in Windows. –  A.D. Feb 4 '13 at 16:52
    
Kernel updated to 3.7.4 no change. –  A.D. Feb 4 '13 at 18:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.