Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 16GB usb flash drive and I made it bootable to install Linux Mint. But for some reason, I couldn't install and did an unsafe eject.

Now, I cannot mount the drive, neither on Windows nor Linux.

If I run 'sudo fdisk -l /dev/sdb', following shows,

Disk /dev/sdb: 16.0 GB, 16008609792 bytes
64 heads, 32 sectors/track, 15267 cylinders, total 31266816 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x4c66d349

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           0     1982463      991232   17  Hidden HPFS/NTFS

Is my flash drive dead? How can I make it work again?

share|improve this question
3  
Always run fdisk on the raw device - so fdisk -l /dev/sdb. The file system may just need to be checked. If the drive has been partitioned, then you should run fsck on the partitions. This may get the drive to a point of being usable without needing to reinitialize it – Petesh Feb 4 '13 at 17:40
    
Thank you very much for your comment. I updated my post. As you can tell, I am new with these stuffs. I never used fsck. Could you please explain a little bit more? – Rakib Hasan Feb 4 '13 at 17:47
    
you can try sudo fsck /dev/sdb1 to check the file system – Petesh Feb 4 '13 at 17:59
    
I am getting the following ... fsck from util-linux 2.20.1 fsck: fsck.iso9660: not found fsck: error 2 while executing fsck.iso9660 for /dev/sdb1 – Rakib Hasan Feb 4 '13 at 18:02
    
it sounds like the partition that was created is a cdrom-style file system. I've added an answer for reinitializing the device so that it can be used again – Petesh Feb 4 '13 at 18:10
up vote 5 down vote accepted

Depending on what you want to do, you have a few options.

You can erase the content of the device and start again:

sudo mkfs.vfat -I /dev/sdb
sudo hdparm -z /dev/sdb
mkdir /tmp/x
sudo mount /dev/sdb /tmp/x

You can try checking the file system on /dev/sdb1, but based on comments from the op, it looks like it's a cdrom image, so it's read-only.

share|improve this answer
    
It worked like a charm! Appreciate your help. – Rakib Hasan Feb 4 '13 at 18:36
    
@Petesh This saved me too. Thanks! – Korgan Rivera Dec 15 '13 at 20:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .