Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Basically, I am doing various tests with Linux/BSD and USB booting at the moment.

I had a live CD for a firewall that offered to partition a (hard) disk. I tried to use my flash drive for this - It is a 1GB memory stick and in FreeBSD, The image I had stated it needed to format a swap slice of 8GB - I clicked next and got an exception in the installer about out of bounds... next thing I know, I can't use the drive at all.

Previously, going to diskpart on Windows and simply issuing the clean command wipes the partition and I can reformat/partition - however, I keep getting read only errors:

Sticking the disk in shows :

enter image description here

Trying to format shows :

enter image description here

Extra error:

enter image description here

Going in to diskpart shows the following:

DiskPart has encountered an error: The media is write protected.
See the System Event Log for more information.

Trying to look at the flags manually shows:

DISKPART> attributes disk
Current Read-only State : Yes
Read-only  : No
Boot Disk  : No
Pagefile Disk  : No
Hibernation File Disk  : No
Crashdump Disk  : No
Clustered Disk  : No

DISKPART>

I have tried to manually clear the flag through attributes disk clear readonly, and despite success, I guess this relates to the main read-only flag and not the current one...

DISKPART> attributes disk clear readonly

Disk attributes cleared successfully.

DISKPART>

I have only used this USB stick a few times and I just can't (or don't want to) believe it went faulty this quick.

I have not tried any formatting/partitioning in BSD as it is beyond me - but that is where it was created.

Can anyone recommend anything? Or is the disk just damaged?


edit -

What makes me think this is salvageable is that I have had a lot of USB drives go bad over the years, however, they usually become completely invisible - either nothing happens when you connect or it is the equivalent of sticking a USB card reader with no media in (you see a new device, but not disk mounted)... I have NEVER seen a disk actually state the capacity and seem ok, but just not read.

In addition, what I did just doesn't seem that much out of the ordinary!

Anyway... crossing my fingers.

share|improve this question
    
Are you willing to download a non-Windows, non-BSD disc image, boot from that, and then reformat your USB drive? –  Kruug Feb 4 '13 at 17:52
    
Tried Gparted - got no where :( If you can recommend anything, I am happy to do anything! –  William Hilsum Feb 4 '13 at 17:57
    
Can you expand on got no where with GParted? What process did you go through? –  Kruug Feb 4 '13 at 17:59
    
tried out partitioning and formatting tool under administrative tools? –  spexy Feb 4 '13 at 17:59
    
try formatting it using a linux os. –  spexy Feb 4 '13 at 18:00

2 Answers 2

Considering what you've already tried, there are only three possible solutions I can think of:

  • The HP USB Disk Storage Format Tool 2.2.3 does a low-level format. It can format some USB flash drives that other tools cannot.

  • Some flash drives have an almost invisible write-protect switch that can be accidentally triggered. Inspect your drive carefully and read the documentation.

  • Some manufacturers provide firmware upgrades and/or factory restore tools for their USB flash drives. I've recovered a read-only SSD with a firmware upgrade in the past.

If the low-level format doesn't work and your drive has neither the switch nor firmware utilities available, there's not much you can do. I speak from vast experience in faulty flash drives...

I have only used this USB stick a few times and I just can't (or don't want to) believe it went faulty this quick.

Usage has nothing to do with it. I'm still using a flash drive I got 6 years ago, but the last two I bought already failed. One after a month (with the exact same problem), the other one after a couple of days (the partition table kept getting corrupted).

share|improve this answer

Go to the GParted site and download the ISO image:

http://gparted.sourceforge.net/livecd.php

Then, burn the CD, boot from the CD, plug in your USB stick, and reformat and repartition.

The Disk Management tool on Windows is only good for FAT or NTFS partitions. It does not recognize any other type of partitions like Linux can. So, since you used BSD to write to the USB stick, Windows will not recognize it.

share|improve this answer
    
GParted hasn't worked for him...see his post. –  Kruug Feb 4 '13 at 20:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.