Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently switched from Ubuntu 12.04 to Linux Mint 14. One thing that is mysteriously not working is autocompletion (tab) and history (uparrow) in coffeescript repl (coffee command). Instead of completing it puts literal tab and instead of showing previous statements it puts ^[[A. Happens in every kind of terminal ie. guake, gnome-terminal and text terminal. The same in node repl works as intended. I did some googling but without success.

Where should I start troubleshooting?

share|improve this question
    
Well, I can answer this myself now, but SE won't let me do it for next seven hours :P I'll post my answer later. –  Tadeusz Łazurski Feb 4 '13 at 18:48

1 Answer 1

up vote 0 down vote accepted

Ok, I did some more googling :)

In short:

sudo apt-add-repository ppa:chris-lea/node.js-libs
sudo apt-add-repository ppa:chris-lea/libjs-underscore
sudo apt-get update
sudo apt-get upgrade

This will upgrade your coffeescript to latest version (which is 1.4 now). I assume you already use latest node.js from ppa:chris-lea/node.js

It seems there was an issue with coffeescript 1.3.* and node 0.8.*.

Background info

Hope that will help someone :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.