Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My DLNA receiver (Marantz 1602) does not display all items from my Windows Media Player (v12.0.7601.17514) playlists. Some playlists show all, some show only a few, some show none. This applies to playlists that are stored on and streamed from my Windows 7 PC, as well as to the same playlists that are stored on and streamed from a NAS media server (WD MyBook Live 2TB).

The playlists are in default .WPL file format, and I cannot find any difference in SMIL XML-format of the contents of the files:

<?wpl version="1.0"?>
<smil>
    <head>
        <meta name="Generator" content="Microsoft Windows Media Player -- 12.0.7601.17514"/>
        <meta name="ItemCount" content="99"/>
        <author/>
        <title>Title</title>
    </head>
    <body>
        <seq>
            <media src="..\Artist\Song.mp3" cid="{GUID}" tid="{GUID}"/>
            <media src="..\Artist\Album\Song.mp3" cid="{GUID}" tid="{GUID}"/>
            <media src="..\Artist\Song.mp3" tid="{GUID}"/>
            <media src="..\Artist\Album\Song.mp3" tid="{GUID}"/>
        </seq>
    </body>
</smil>

All 99 items are in either one of those 4 formats, and all src attributes use relative paths.

What could be the cause of these incomplete playlists at my receiver?

share|improve this question
1  
Not a solution, but if the receiver supports M3U playlists can you try those instead? –  Karan Feb 5 '13 at 3:04
    
@Kar Thanks, that's a fantastic working alternative! –  NGLN Feb 5 '13 at 19:29
    
Excellent, and as a bonus there's far more widespread support for the M3U format as compared to MS' WPL. Edit: Perhaps you can report this WPL issue as a bug to Marantz. –  Karan Feb 5 '13 at 19:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.