Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Fed up with emacs22 that came with Xcode, I set out to upgrade to emacs24. I do not want to overwrite the system defaults, and do not want to mess up with it either, so I tried to install emacs in a custom directory other than /usr/local/.

Say I set the prefix to CUSTOM_DIR/emacs-24.2. I built and installed emacs 24.2 to the CUSTOM_DIR/emacs-24.2 directory, so bin/, libexec/, share/, and var/ are all there. (Yes, I have manually checked all required files; the installation is totally complete in the custom directory.) But when I tried to run the new version of emacs, I got the following error messages:

Warning: arch-dependent data dir (/usr/local/libexec/emacs/24.2/x86_64-apple-darwin12.2.1/) does not exist.
Warning: arch-independent data dir (/usr/local/share/emacs/24.2/etc/) does not exist.
Warning: Lisp directory `/usr/local/share/emacs/24.2/site-lisp' does not exist.
Warning: Lisp directory `/usr/local/share/emacs/site-lisp' does not exist.
Warning: Lisp directory `/usr/local/share/emacs/24.2/lisp' does not exist.
Warning: Lisp directory `/usr/local/share/emacs/24.2/leim' does not exist.
Error: charsets directory not found:
/usr/local/share/emacs/24.2/etc/charsets
Emacs will not function correctly without the character map files.
Please check your installation!

So obviously emacs's search path was not affected despite the option --prefix=CUSTOM_DIR/emacs-24.2 I specified when running configure. How do I fix this? Is there any configuration files I need to change, or do I need to add some configuration options when configuring and building emacs? (I built emacs 24.2 from tarball.)

P.S. Please do not suggest other ways of installation. I do know how to install emacs 24, either by installing to /usr/local/, which appeared to have no problem at all; or with MacPorts or similar projects; or by directly running from the command line component found in Emacs.app binary distribution. I simply want to fix this very problem. Thanks.

share|improve this question
    
@Dror Well, thanks, but perhaps you did not read the last paragraph. I know a couple ways for what I want; I just want to solve the problem at hand, since it shouldn't have occurred. –  KevinSayHi Feb 5 '13 at 16:23
    
@Dror As you can see, you suggestion has already been listed in the last paragraph. I've known that approach well. –  KevinSayHi Feb 5 '13 at 16:24
    
Sorry. My bad! I missed the last paragraph indeed. –  Dror Feb 5 '13 at 19:56
add comment

1 Answer

up vote 0 down vote accepted

Some time ago I used to build emacs from source:

git://git.savannah.gnu.org/emacs.git

in a custom dir with:

./autogen.sh
./configure --prefix=$HOME/cmp/soft/sft/Emacs --enable-link-time-optimization
make bootstrap
make install
share|improve this answer
    
Well, what should I say... I've long given this up, but thanks for answering anyways. –  KevinSayHi Mar 28 '13 at 5:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.