Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

As you can see below, there is no hybrid sleep option like there is in Windows 8. Is it enabled by default with sleep or hibernation or is it gone entirely?

no hybrid sleep <- Windows 8 vs Windows 7 -> has hybrid sleep

Edit:

PS C:\Users\User> powercfg.exe -a
The following sleep states are available on this system:
    Standby (S1)
    Hibernate
    Fast Startup

    The following sleep states are not available on this system:
        Standby (S2)
            The system firmware does not support this standby state

        Standby (S3)
            The system firmware does not support this standby state

        Standby (Connected)
            The hypervisor does not support this standby state.
            The system firmware does not support this standby state

        Hybrid Sleep
            Standby (S3) is not available.
            The hypervisor does not support this standby state.

Is there a way to enable S3 in BIOS or does my motherboard just not support it?

Update: Hybrid Sleep is usable on Win7 64 on the exact same machine with the same drivers. Sounds like it's a limitation in Windows 8 but I would like to know what's missing if that isn't the case.

share|improve this question
1  
I've heard this is often a driver issue (it should still be there in Win8). What system/systems are you using? –  Marcus Chan Feb 5 '13 at 2:13
    
custom pc - msi 770t-c45 motherboard and amd triple core cpu –  Enigma Feb 5 '13 at 2:43
1  
AFAIK, hybrid sleep is only for desktops. But since yours is a custom one, I don't know why the option isn't there. Mine is a Windows 8 laptop so I don't have the hybrid sleep option. However, I'll check with the Windows 8 PC at home and let you know –  pratnala Feb 5 '13 at 8:15
    
The OP's system is a desktop. But yeah, I don't know why it wouldn't show up. –  Marcus Chan Feb 7 '13 at 4:58
    
Given that Microsoft likes taking out features almost as much as they like putting them in, it doesn't seem unreasonable that they simply didn't want to support it anymore. I don't know how that could be in their favor though if that were the case. Hybrid sleep was a definite move in the right direction. –  Enigma Feb 7 '13 at 14:49

2 Answers 2

up vote 4 down vote accepted

Windows 8 still has hybrid sleep. It's usually enabled for desktops, and is disabled for laptops.

I have hybrid sleep on my laptop with Windows 8:
Power Options: Hybrid sleep option in Windows 8

Check Device manager whether there are any unrecognized devices and install drivers if there are any.


The following commands should be run in Command Prompt (cmd.exe) with Administrative privileges.

Check which sleep states your system supports:

powercfg -a
The following sleep states are available on this system:
    Standby ( S3 ) Hibernate Hybrid Sleep
The following sleep states are not available on this system:
Standby (S1)
    The system firmware does not support this standby state.
Standby (S2)
    The system firmware does not support this standby state.

If you cannot see S3 sleep in the list, then there's an issue with drivers. Check for driver updates on the manufacturer website.

Enable Hibernate:

powercfg -h on

Update:

Since it's still unknown which device does not support hybrid sleep, I propose to list all the devices that support different sleep states and then filter the list by comparing.

powercfg /devicequery all_devices
powercfg /devicequery S1_supported
powercfg /devicequery S2_supported
powercfg /devicequery S3_supported
powercfg /devicequery S4_supported

The first command lists all the devices in your system. We already know you system supports S1 (light sleep), so the list for S1 state should also contain all the devices.

The interesting part is S2 (deeper sleep) and S3 (deepest sleep). By subtracting the entries in S3 and S2 lists from the all devices, you will see which devices do not support these deeper sleep states. Then you can try to disable a device (if it's not essential for computer operation) or try to change its driver, and so on.

I believe S3 sleep is what required for hybrid sleep.

In the list above, S4 is hibernation. All your devices seem to support it as well.

share|improve this answer
    
So how can I get mine enabled? All device drivers are installed and none are unrecognized. –  Enigma Feb 8 '13 at 16:53
1  
@Enigma I have updated my answer with commands to check available sleep states and to enable hibernation. Also look for errors in the Windows system log: Windows + X, Computer Management, Event Viewer, Windows Logs, System. –  Alexey Ivanov Feb 12 '13 at 6:37
    
I made an edit to the original post. Hibernation and sleep are both visible and work. It is just Hybrid sleep that is not visible. –  Enigma Feb 13 '13 at 2:02
    
I checked in bios and S3 is selected as is last state for the resume option. –  Enigma Feb 14 '13 at 0:09
    
@Enigma So now you know “Hybrid Sleep - Standby (S3) is not available.”, and that's the reason why you cannot configure hybrid sleep. The other question is why it's not supported in Windows 8 whereas it was in Windows 7. The most likely answer to this question is drivers. I would start by looking for updated drivers on the motherboard manufacturer website. If there are no drivers for Windows 8, you can try drivers for Windows 7, yet it does not always work. The default drivers Windows installs may not “know” everything about the hardware, and some features can be unavailable. –  Alexey Ivanov Feb 14 '13 at 13:31

It seems that your answer is right there. It's telling you that hyper v doesn't support that mode. Disable it and try again. Otherwise, it has to be a driver issue, as one or more drivers are working fine with one and not the other. The system may only recognize the most crucial lines of the driver programming yet not recognize less crucial ones. Ergo, the hardware runs, but is not compatible with the power settings in which you desire.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.