Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently upgraded to Windows 8 Pro, and so far I have no real regrets. However I'm having issues with various "Modern UI" apps, and it has gotten to the point where it's widespread enough that I doubt it's app-specific issues. The issues seem to revolve around connectivity to external services

For example, I tried using MetroTwit. When I click the "Sign in with a Twitter account" button, it shows the loading animation for a few seconds with the message "Contacting Twitter..." then goes back to the "Let's get started" page.
Another example is Cumulo. It asks me to connect to cloud storage providers, but whenever I choose one to connect to, it does something similar; just loads for a second then goes back to where it was before.
An interesting case is Zipwhip - an app to sync SMS messages between my Android phone and Windows 8. While the app is closed, I receive push notifications of new text messages as I should. When I respond to a text message, the message is sent correctly (so the request is sent to the server correctly), but nothing appears in my message history (no response from server?). Also, while the app is open, when I get a new text message, nothing happens. No notification, no appearing in my message history. But when I close the app (drag from top to bottom) the notifications start working again.
There's other example's too; Pulse news reader not connecting to Facebook, etc.

In general, the internet works fine. I'm downloading apps and updates from the Store, browsing with the IE 10 Modern UI, using ebay and Google Search, etc, etc. Haven't had any problems on the Desktop, either.

I've tried uninstalling and re-installing apps, I've tried the app troubleshooter (AppsDiagnostic.diagcab) linked from this Microsoft article... I've also contacted the developers of Zipwhip, Cumulo and MetroTwit looking for answers (nothing so far). My best guess is that it's some sort of security issue, but I don't know where to start looking. Does anyone have any ideas?

share|improve this question
    
Which AV are you using? –  pratnala Feb 5 '13 at 4:41
    
Nothing. Just the built-in windows defender. –  death_au Feb 5 '13 at 4:43
    
Run the Apps troubleshooter. You can download it by searching on the Web or use this link sdrv.ms/UTI2O6 I uploaded it onto my SkyDrive. See if it reports any errors and restart when it asks you to. The file name is AppsDiagnostic.diagcab –  pratnala Feb 5 '13 at 4:48
    
That's the same troubleshooter I linked in my question. I've run it a couple of times. It usually tells me it's fixed some security settings and I need to restart. I then restart and the problem still exists. –  death_au Feb 5 '13 at 6:37
    
I'm sorry I missed the last para. Did you check the event log? –  pratnala Feb 5 '13 at 8:11

1 Answer 1

I had similar problem. I was unable to connect to windows 8 store and apps. However I can access internet in all browsers and other applications. You need to install fiddler and them exempt all apps. It worked for me. Here is detailed tutorial with screenshots - Windows 8 store

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.