Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am attempting to get a Logitech USB headset to work on my Debian Squeeze computer. However, no matter what I do, there is no sound. I've already tried everything I could find on Google with no luck.

Originally, cat /proc/asound/cards listed the internal card in slot 0 and my headset in slot 1. After following the suggestion to rename /lib/modules/2.6.32-5-amd64/kernel/sound/pci/hda/snd-hda-intel.ko so it can't be found, it no longer reports the internal card, but my headset is still in slot 1.

I also tried editing /etc/modprobe.d/alsa-base.conf to comment out the last line and add options snd-usb-audio index=1, but nothing I did to this file had any effect. I also tried rebooting the computer in between each change, but that didn't help.

Update: I reenabled the /lib/modules/2.6.32-5-amd64/kernel/sound/pci/hda/snd-hda-intel.ko module, so both the internal card and the headset showed up.

Then I installed PulseAudio using the directions at http://zitzlinuxblog.blogspot.com/2010/10/this-is-updated-version-of-how-to-i_07.html, but this only made things worse! Now the only thing that shows up under sound preferences and pavucontrol is "Dummy Output".

So what can I do? I'm at my wits end.

share|improve this question
    
Why are you setting index=1 when you want it to be at index 0? Why aren't you just selecting the headset in the PulseAudio configuration? – CL. Feb 5 '13 at 8:24
    
Because that's what I found online suggested. Anyway, I'm not sure how to do the PulseAudio thing but I'll look into it. – Antimony Feb 5 '13 at 13:25
    
@CL What do you mean by "selecting the headset in the PulseAudio configuration"? How do I do that? – Antimony Feb 22 '13 at 17:35
    
Something like pavucontrol's configuration tab. – CL. Feb 22 '13 at 19:12
    
@CL I installed PulseAudio, but that only made things worse! Now the only thing that shows up under System Sound Preferences and Pavucontrol is "Dummy Output". – Antimony Feb 22 '13 at 22:45

You can try the following:

Run sudo alsamixer in a terminal, press F6 and select your headset.

If you have selected it, check that the volume bar does not have "MM" on it. If it does, it's muted. Use the 'M' key to unmute it.

share|improve this answer
    
I no longer have the headphones or the computer in question, so it's a bit obsolete. But thanks anyway. – Antimony Jun 10 at 16:44
    
Didn't realize this was asked 3 years ago, sorry. – AcridBrimistic Jun 10 at 16:58
    
It's perfectly OK to answer old questions! We always welcome people to share their solutions. – Ben N Jun 10 at 17:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.