Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I know there's a wiki entry that shows how to disable IPv6 in Debian Squeeze, but that's a 2.6.* kernel.

What about 3.2.* kernels running Wheezy?

share|improve this question
at least '/sys/module/ipv6/parameters/disable_ipv6' still exists for Kernel 3.2.0xxx – sparkie Feb 5 '13 at 10:38
@sparkie yeah but says nothing about /sys/module/ipv6/parameters/disable_ipv6 but /etc/sysctl.d/disableipv6.conf – JohnnyFromBF Feb 5 '13 at 14:18

If you do sysctl -p, the reboot isn't necessary. It worked for me, but I prefer to keep params in single file, so I put the line above in the sysctl.conf file.

Just to be sure, I put a line about every device, so my solution is adding the following lines to /etc/sysctl.conf:

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1
net.ipv6.conf.eth0.disable_ipv6 = 1
net.ipv6.conf.eth1.disable_ipv6 = 1
net.ipv6.conf.ppp0.disable_ipv6 = 1
net.ipv6.conf.tun0.disable_ipv6 = 1
share|improve this answer
Isn't net.ipv6.conf.all.disable_ipv6 = 1 enough? At least iIt did the trick for all interfaces on my machine. – Eugene Beresovsky Apr 16 '15 at 23:14
Worked like a charm thank you! – Rudi Strydom May 16 '15 at 20:24
Thanks for this! For some reason, on my Raspberry Pi just disabling via net.ipv6.conf.all.disable_ipv6 didn't work; adding an explicit line for my adapter did the trick! – Doktor J Jun 12 at 19:05

Disabling IPv6 on more recent systems works the same way as described in the Debian wiki:

Disable ipv6 in kernel : echo net.ipv6.conf.all.disable_ipv6=1 > /etc/sysctl.d/disableipv6.conf will disable ipv6 at next reboot.

Keep in mind that, whatever problem you are having, this should be an absolute last resort after you have exhausted all other options for fixing the problem. IPv6 is not optional and you will have to turn it back on sooner or later.

share|improve this answer
Interestingly I still have ipv6 showing up after following the instructions and verifying the settings listed on the wiki pages persisted after reboots. It might have something to do with the fact that this is running on a vm hosted by someone else. – ConstantineK Dec 6 '13 at 16:44
@hobs Yes, some VM providers restrict what changes can be made to the guest's network configuration. Typically OpenVZ based ones. In this case, you definitely should forget about disabling IPv6 and instead try to resolve the actual problem. – Michael Hampton Feb 4 '14 at 14:40
Definitely. I had no interest in doing this but as you may know, many legacy pieces of software with no future development have issues, and that is what I was working with. So, I wish! – ConstantineK Feb 4 '14 at 14:46
This didn't work for me. Jawa's approach did work though. I'm using BAMT1.1, not really sure which version of debian it's based on. – womp Feb 27 '14 at 6:16
@MichaelHampton OpenVZ isn't a VM system, it's a container/chroot jail-based system, which is probably why you can't mess with its network settings like this... – Jules Apr 10 at 1:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .