Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A while ago, I downgraded from Java 7 to Java 6 on my Mac, using these instructions.

A few days ago, and for no apparent reason, this has stopped working (in my web browser) and Java just doesn't seem to be answering at all. So I tried — without having any clue of what I was doing — to reinstall Java 7, then to downgrade again using the same instructions. That failed miserably of course. When I type in the following instruction from the Apple web site in the Terminal:

sudo mv /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin /Library/Internet\ Plug-Ins/disabled

The Terminal says "Not a directory".

When I type in:

java -version

I get:

java version "1.6.0_37"
Java(TM) SE Runtime Environment (build 1.6.0_37-b06-434-11M3909)
Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01-434, mixed mode)

The Java Panel is also present in my System Preferences... no clue why. When I tried the set of instructions earlier though, I managed to make it disappear, but Java didn't work in my browser at all.

Also, there is no application called Java Preferences in /Applications/Utilities, and when I go to the Java Panel in System Preferences and try to visualize the versions I have (under the "Java" tab) it only tells me about 1.7. I have seen a screenshot where the author also had "1.6 (system)" but this isn't the case for me.

Of course, this is most likely due to the fact I had no idea what I was doing, but I hope you can find a solution.

Any help? I'm on Mac OS X Lion 10.7.5

share|improve this question
1  
Possibly related to a security vulnerability. Search the forum for '[java] [osx]' sorted by newest and you'll probably find some of them. –  Andrew Thompson Feb 5 '13 at 9:58
    
I don't understand why it should be related to a security vulnerability. I tried to look those up but couldn't find anything very useful given my knowledge. Also, update: Java 7 seems to be working in my web browser (although I tried to revert) –  Konrad Feb 5 '13 at 10:25
add comment

migrated from stackoverflow.com Feb 5 '13 at 13:26

This question came from our site for professional and enthusiast programmers.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.