Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My girlfriend takes alot of pictures and up until the other day has imported them to her computer without trouble. Plug in camera, window pops up, click Import. Now that doesn't work anymore. Everytime she tries to plug the camera in the little bubble near the clock pops up and says "Installing drivers". Then comes the usual "Failed to install drivers". I have tried my neighbour's camera on her computer and the result is the same. It still works on my computer so now we have to use that on to import her pictures. It's very annoying that I can't seem to find the cause of the driver error.

Tested cameras: Canon EOS 400D and 1000D
Non-working computer: DELL Latitude 6520 with Windows 7 Pro
Working computer: DELL Precision M6500 with Windows 7 Enterprise
Also I've tried with different cables.

I tried downloading drivers but haven't found any. On Canon's website it says that no drivers are needed since they are already integrated in Windows 7. Anyone know of this problem?

share|improve this question
    
Did you recently install updates to the Windows 7 Pro computer? –  John Feb 5 '13 at 13:50
    
You could try System Restore and restore back to a time when it did work –  Kryten Feb 5 '13 at 14:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.