Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was using a Windows Remote Desktop Connection to a Windows Server 2008 R2 terminal session on my Windows 7 PC and held the shift key down for more than eight seconds whilst I was thinking about what to type. This activated Filter Keys on the Windows 7 PC. I closed the Filter Keys panel without activating the feature and went back to the RDP session. I then discovered that the keyboard no longer worked in the RDP session. Disconnecting the session and reconnecting had no effect on the problem.

I have Googled and found no solution.

How do I re-enable the keyboard without having to reboot my logged in RDP session?

share|improve this question

migrated from stackoverflow.com Feb 5 '13 at 16:26

This question came from our site for professional and enthusiast programmers.

2 Answers 2

up vote 0 down vote accepted

Using your mouse,

  1. go to the control panel
  2. scroll to make the keyboard easier to use link
  3. uncheck use filter keys
  4. press ok
share|improve this answer
1  
This works when performed on the Terminal Server session, thanks. –  Rusty Shackleford Feb 15 '13 at 9:16

What i will suggest is to open the services panel from your workstation to the remote. restart these services:

  • Remote Access Connection Manager
  • Remote Desktop Services
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.