Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Making my first build from scratch. I've managed to boot to bios just fine with everything except GPU plugged in, but when I plug in my GFX card, suddenly, black screen. I've tried both onboard and GPU dvi ports when the GPU is plugged in, but still no signal. As soon as I take out the GPU and switch to onboard graphics I can get into BIOS.

Mobo: http://www.newegg.com/Product/Product.aspx?Item=N82E16813157302

CPU: http://www.newegg.com/Product/Product.aspx?Item=N82E16819115233

GPU: http://www.newegg.com/Product/Product.aspx?Item=N82E16814125413

PSU: http://www.newegg.com/Product/Product.aspx?Item=N82E16817151095

EDIT: After putting in a different GPU which I know works correctly from my old rig, I discovered that the problem remains. Unless I am mistaken, this means that the problem must be related to the motherboard (or BIOS maybe?). Does it seem possible/likely that the mobo might be DOA so that when a PCI-E device is used, the pc black screens?

share|improve this question
    
Did you remember to plug the auxiliary power into the card? Are you sure the card even works? –  Shinrai Feb 5 '13 at 18:21
    
Yea, it definitely has power. I am not sure the card works. The fans spin, but that is the only indication that it is working at all. How can I diagnose a DOA GPU? –  guywhoneedsahand Feb 5 '13 at 19:00
1  
I'd try it in another system if you have one handy, but if everything else works I'd probably just assume it's DOA and get a replacement. It could potentially be something else but the odds are not high enough to spend time testing, IMO. –  Shinrai Feb 5 '13 at 19:06
2  
A 7970 GHz has a TDP of only 250W, so not "required by the GPU by itself". And yes, 550W is the suggested PSU, and 650>550. In any case, yeah, I'd RMA the GPU as Shinrai said. My only other guess is it could be an issue with the Lucid Virtu MVP on the mobo. –  Marcus Chan Feb 5 '13 at 19:36
2  
I agree with Marcus, this should be enough juice to at least get the damned thing to power on. GPU virtualization settings are a good thing to check too, though - I'm not familiar with this board but should be an easy BIOS option to find. (You'd think it'd boot to the onboard anyway, though - this sounds more like it's trying and failing to use the discrete) –  Shinrai Feb 5 '13 at 22:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.