Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use alt+tab all day long to switch between windows. When I'm working remotely, I'll use Remote Desktop to log in to my Windows 7 PC at work.

From the host machine, it's simple to alt+tab to switch to get to the remote machine.

However, on the remote machine, alt+tab doesn't allow me to switch back to the host machine, forcing me to use the mouse (gasp!). To be clear, I still want to see the guest machine's applications when I use alt+tab on the guest machine. I just want to be able to see the host machine as one of the options in alt+tab while I'm remoted in.

Is there a way to be able to alt+tab back to the host machine from the remote machine, perhaps via a 3rd-party add-on?

share|improve this question
Is this option set? – Karan Feb 5 '13 at 19:57
@Karan it's set to "Only when using the full screen," which is actually what I want. I still want to be able to use Alt+Tab on the guest machine, but I want to the host machine to show up as an option under Alt+Tab. Question updated accordingly. – Ben McCormack Feb 5 '13 at 21:09

Use ctrl+alt+break to restore the Remote Desktop window, so it is no longer full screen.

Then use alt+tab to switch between applications on the local machine.

When you want to go back to the remote machine, alt+tab to it, and press ctrl+alt+break to restore it to full screen again.

share|improve this answer
Worked for me. For those who don't have a Pause / Break key on their laptop, do a quick search, e.g. "ThinkPad Break Key". I learned that on my ThinkPad T530, I'd have to press Fn + Alt + B to send the equivalent of a Ctrl + Alt + Break. For some reason, using AutoHotkey to send ^!{CtrlBreak} (and many other combinations) didn't work for me—many others experience the same, though AHK did seem to work for some. – Andrew Cheong Dec 26 '14 at 9:27
More ThinkPad specifics - for my Yoga I need Fn + Ctrl + Alt + P to emulate Ctrl + Alt + Break – Matt Bracewell Jun 24 at 14:09

Alt-Insert works in windowed mode, and is almost the same as Alt-Tab.

Alt-PgDown and Alt-PgUp are also useful.

share|improve this answer
Handy, but how does this get back to the open windows on the local machine? It only switches between windows on the remote machine. – Garrulinae Mar 14 '14 at 8:48
You won't see a combined list, but if you Alt-tab for local, those others for remote, you can avoid the mouse entirely. – Nik Mar 14 '14 at 12:16
Thanks for providing info for those of us that run RDC mostly in windowed mode. – Adam Nofsinger Dec 31 '15 at 17:43

On my system (using windows server 2012 R2), I use ctrl+alt+home to get to the remote desktop bar and then alt+tab to move around the windows on local machine.

share|improve this answer
This is the best solution if you want to keep alt-tab working on the remote machine, but want to also be able to switch to local machine quickly. – Wired in Jan 25 at 14:34

Well the Solution is here - Under Remote connectivity terminal (mstsc),Navigate to third tab

"Local Resources" and Select the first dropdown - Keyboard - "On this computer" This is amazing one and make your work much easier and further can switch between host computer and remote comp (in full screen mode)

But could not navigate into remote machine so in case revert the previous settings of dropdown to old menu and use the shortcut to switch between full screen mode and normal mode of remote PC - Control + Alt + Break.

share|improve this answer

For me following scenario worked properly "Local Resources" and Select the first dropdown - Keyboard - "On this computer" Afterwords you should use Alt+PageUp instead of Alt+Tab

share|improve this answer

Win Key + Alt + Tab will work.

share|improve this answer

Try connecting through mstsc (Start->Run->mstsc). I was initially connecting through RDP Client and tried the solution provided above by Josh but it did not work. When I connect using mstsc and applied the solution, it works.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .