Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just installed a plain CentOS 6.3 system. I enabled sshd, and try to connect with Putty.

This works, but here is what I get:

login as: user
Access denied
user@192.168.1.7's password:
Last login: Tue Feb  5 19:03:17 2013 from zzzzzzzzz
[user@db ~]$

Why do I get a spurious Access Denied message?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

This is PuTTY trying the various authentication methods (e.g. GSSAPI) and CentOS replying 'No thanks'.

To get rid of the error, you have to either disable PuTTY's extra authentication methods, or configure them in CentOS's sshd.

Update

A Google search confirmed this to be an issue between PuTTY and CentOS:

http://devio.us/~cyclone/index.php/2011/07/putty-release-0-61-experience/

For the “Access denied” problem.

Most of the time this is caused by the new GSSAPI option in Putty 0.61. Go to Connection: SSH: Auth: GSSAPI an deactivate “Attempt GSSAPI authentication”

If that doesn’t help go to Putty log file by CTRL+Click on your Putty session and open up the normaly hidden menue entry “Event log”. There you should see what caused the access error.

Yes, that was it. Turning off the GSSAPI authentication eliminated the “Access denied” error message for me as well. I still think that I should update the OpenSSH software used by CentOS 5.6. It’s better to be safe than sorry. ;)

share|improve this answer
    
Thanks for your help. –  EB. Feb 6 '13 at 0:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.