Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So on snowleopard, the maxed out window size almost fills the whole screen, except for a slight margin at the very bottom that is only a few pixels. Is there any way to override this or somehow make it extend all the way to the bottom?

As you can see at the very bottom of this screenshot:


share|improve this question

The only option I know is to remove or disable, but it also disables the application switcher, Exposé, Spaces, and makes desktop backgrounds gray. In 10.8 it also disables full screen windows and the Notification Center sidebar.

I have tried searching for hidden preferences for it with gdb, but I haven't found anything.

If you make the desktop background (or the side the Dock is on) black, it's barely noticeable though.

share|improve this answer
You could also move the Dock to the left or right side. While resizing is still affected, moving windows over the gap on a side feels more natural than moving to the bottom, then resizing up IMO. It can also be aligned more easily with the menu bar. – Daniel Beck Feb 8 '13 at 13:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.