Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a AV Receiver plugged into my Radeon HD5670 via HDMI, using ATI HDMI audio. It used to work fairly well on Windows 7 (and Linux too). But I am having troubles with Windows 8. Windows 8 64 bit. Driver is "AMD High Definition Audio Device", version 8.0.0.8809 (also tried the beta 8.0.0.8811), from 2012-12-21. (the graphics driver from the package is version 9.12.0.0).

My receiver (Onkyo TX-SR309) has a variety of regimes of signal processing, which it plugs automatically. On Windows 7 once HDMI was connected and the first audio signal received - it connected the HDMI+PCM mode, and stayed that way until turning off one of the devices implicated. On Windows 8 however, it turns off the HDMI+PCM mode soon after playback stops. I know it's software related since Foobar2000 turns off the HDMI+PCM mode even between tracks, while in AIMP3 I can switch tracks and even pause for a short while, without this switch happening.
The reason this is frustrating is because it takes about 2-3 seconds for the switch of audio modes to take place on the receiver. It's so bad that I can't even perform room correction since the sound plays during the receiver mode initialization.

I've had no business with handling audio streams in software and drivers, so I can only speculate that my receiver holds the HDMI+PCM mode as long as the audio driver has an open data stream with the receiver.

So I am asking: how do I make the link persistent, so it won't disappear after I stop playback of any audio stream.

share|improve this question

It seems like Windows 8 will cease outputting an audio stream. A tool called hdmiOn may solve your problem.

Update

Sorry, I was thinking of the wrong tool. You may be experiencing the "silent stream bug", and there's a tool called AVR Audio Guard which may help.

share|improve this answer
    
Thank you for this answer. It may actually help, but unfortunately I can't test it any more, since I've switched to DTS streams over S/PDIF from a "DTS Connect" enabled audio card. If anyone can confirm that this actually works, I'll mark this as the correct answer. – AlexanderMP Oct 5 '13 at 10:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .