Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to compile PHP with a MSSQL extension. I get this error:

WARNING: unrecognized options: --with-php-config

when I try to run ./configure --with-php-config=/usr/local/php5//bin/php-config from the root of my PHP install folder. The PATH is different than the norm because I installed PHP over CURL from this server in Switzerland called LIIP.

How do I address this error?

share|improve this question

migrated from serverfault.com Feb 6 '13 at 7:51

This question came from our site for system and network administrators.

    
What does # ls /usr/local/php5//bin/php-config return? –  Stephan Feb 5 '13 at 21:48
    
/usr/local/php5/bin/php-config –  sehummel Feb 5 '13 at 21:49
    
Ignore the double / –  sehummel Feb 5 '13 at 21:50
    
No worries; the system won't care about double //, I just wanted to be sure you had a php-config file in the location. –  Stephan Feb 5 '13 at 21:56
    
It looks like I do. Other suggestions? –  sehummel Feb 5 '13 at 22:00

1 Answer 1

up vote 0 down vote accepted

Ah, I went dyslexic on you.

Here's a great article:

http://blog.benjaminwalters.net/?p=10

The gist is, why would you want to declare 'with-php' when you're compiling php?

G'luck!

share|improve this answer
    
I still get the same error. –  sehummel Feb 5 '13 at 21:59
    
Sorry to hear that; I've updated my answer, I hope it helps. –  Stephan Feb 5 '13 at 22:13
    
Thanks. That's similar to what I was doing, but thanks. –  sehummel Feb 5 '13 at 22:16
    
That worked. Thanks, Stephan. –  sehummel Feb 5 '13 at 22:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.