Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to install Debian Linux (newest stable as of 6.2.2013, x64) on a Dell OptiPlex 740 I keep getting this error message right after I choose "Install" from the main menu (the hdd is empty):

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(254,32)

I have tried using a liveCD and that won't boot up either, screen just goes almost white with a white cursor blinking in the top left corner.

Windows 7 Ult x64 installs fine on the same computer. I have installed Debian on several computers (servers) before this and never had any problems. What's wrong?

share|improve this question
    
What happens on the lines above this error message? It will usually give you some more info about the partitions it's found and what-have-you. Also, what type of drives are you using? –  Xyon Feb 6 '13 at 13:04
    
Isn't the optiplex an UEFI one? There where a lot of issues in the last weeks with samsung (+others) uefi laptops and Linux (up to no longer working samsung notebooks) –  Offler Feb 6 '13 at 13:08
    
Have you checked the md5sum of the iso you downloaded? –  terdon Feb 6 '13 at 13:21
    
@Xyon: There is just this one line. The drive is your common SATA2 hdd. –  Akke Feb 6 '13 at 13:27
    
@Offler: How can I check this? –  Akke Feb 6 '13 at 13:27
show 5 more comments

1 Answer

Two things to check:

  • Try booting from USB, not CD, as sometimes CD drives cannot be detected on startup
  • In the BIOS, set the SATA controller mode to AHCI, potentially IDE, but never RAID, and also "AHCI (Linux)" often does not work with Linux.
share|improve this answer
    
Thanks, I'll try :) –  Akke Feb 7 '13 at 12:21
    
I've done the SATA controller configuration on many (10+) other motherboards, but can't seem to find it on this one. I made a USB netinst drive and it still gives me the same error msg. What do? –  Akke Feb 7 '13 at 13:06
    
Check the manual, on page 8 it talks about AHCI settings. –  Stefan Seidel Feb 7 '13 at 13:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.