Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have exactly same task like here:
Windows 7 - Add shell command for .png file

But this solution doesn't work in Windows 8 for unknown reason only for PNG files. And I don't know why.

I tried some other formats, PSD for example. Adding new commands works fine:

enter image description here

But exactly same commands for PNG don't show up in Windows Explorer:

enter image description here

I tried rename of class and commands, or use only user structure HKEY_CURRENT_USER\Software\Classes. I tried edit access rights permissions also. Nothing helps.

I suppose that there are some MIME type commands assigned to PNG format, but where I can find them in registry? Or something else?


I tried FileTypesMan and Types apps also. Some standart commands is listed, custom commands also here, but none of them work:

enter image description here

share|improve this question
Have you tried any of the other proposed answers from the other question? – Oliver Salzburg Feb 6 '13 at 13:21
Those two examples aren't the same. PhotoShop.Image.9 is another registered type, I don't think you can just create a key under Classes as you've done for png. – cjb110 Feb 6 '13 at 13:39
@OliverSalzburg, yes. I tried FileTypesMan and none of commands don't work. Even standard ones. – Dmitry Zorin Feb 6 '13 at 14:11
@cjb110, no. I created key for ".xxx" under Classes with "MySuperXXXType" class below, add some custom command and all work fine. It's always worked in all previous versions of Windows. But same actions don't work for PNG for some reason. – Dmitry Zorin Feb 6 '13 at 14:32
Have you tried first deleting all entries for .PNG so that PNG images are not recognised by Windows at all? – Karan Feb 8 '13 at 0:30

This might be a bit late but after hours of research why this doesn't work on the pngfile, giffile, jpegfile and possible other file extensions which are considered graphics/pictures/images and therefore executed with the Windows 8 Photo App, I have found the cause.

The actual cause is the app itself, all graphics are opened with the Windows 8 Photo App by default and the context menu items are not displayed. However, after changing the default application to the standard Windows 7 Photo Viewer, the items were displayed and working as intended.

Hopefully this will help other people such as me who came from google but found no solution for this particular problem.

// 02.04.2014 Just found out that even though doing the things above doesn't really much help when it comes to .gif files. So I've looked where the photo app stores it's shell data and found it: The key is the name of the binary value located at HKEY_CLASSES_ROOT\.gif\OpenWithProgids. It's the file with the prefix App which is following some kind of encryption characters. Just look up this key and you will get straight to the shell key for the app. Make your changes and you should see the new context menu item popping up if you have set the Windows 8 Photo App as default program.

share|improve this answer

I would recommend the Types utility, its a bit plain looking but handles any assocation stuff I've had to do.

One note with Windows 8 when you search for Types remember to select Settings from the right charm, as it installs as a control panel app.

share|improve this answer
Unfortunately this don't work. Types utility shows custom commands. But editing them does nothing. Even standard ones. – Dmitry Zorin Feb 6 '13 at 14:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.