Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Sony Vaio, SVE14A2V1RP, with Windows 8 pre-installed; went legacy / disabled Secure Boot, erased everything and installed Windows 7. Everything works just fine, except the laptop does not go to sleep when the lid is closed. this option is simply not available at the power management, the only two possibilities is to "do nothing" or "shut down".

I've been reading that this somehow depends on the video drivers. In the device manager, the Intel card is found, but the other (Radeon 7670M) is not. Tried installing all the various drivers, to no avail.

Suggestions?

PS the device id is PCI\VEN_1002&DEV_6840&SUBSYS_9096104D&RE…

share|improve this question
    
Guys, did the following - ran cmd as admin, powercfg -HIBERNATE ON, made it so the hatch closing hibernates. Solves some issues, but no sleep available, and sucks that it cannot use Radeon. Any comments are welcome. –  denis12345 Feb 6 '13 at 21:00
    
Have you checked AMD's site for Windows 7 drivers for the Radeon? –  danielcg Feb 6 '13 at 21:16
    
Check the Sony site for the Windows & drivers for the same video card on an earlier version of the laptop. –  Dave M Feb 6 '13 at 21:59
    
I have checked for the drivers on AMD's website - when trying to install them, says that the system is incompatible, so I go over to driverscollection.com, find the drivers for an earlier version of the laptop, only to receive the same error while opening Catalyst (in both cases, the installer says that the installation went fine). I am stupefied. –  denis12345 Feb 7 '13 at 8:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.