Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to set up an environment for iOS development. My Mac OS X VM is working excellently, but I can't seem to mount my iPad.

The iPad does not show up under My Computer with iTunes installed. Unmounting the iPad from iTunes did not help. I tried uninstalling iTunes, after which the iPad did show up under My Computer, but I'm not sure if unmounting it somehow would help. I even have a filter set under the VirtualBox VM Settings.

Throughout all these steps, I get the same error when trying to mount the iPad on the guest:

Failed to Attach USB Device Apple iPad...

error:

Failed to attach the USB device Apple Inc. iPad [0210] to the virtual machine Mac OS.

USB device 'Apple Inc. iPad' with UUID {2f498ad0-976a-4173-b83a-a47df2b8278e} is busy with a previous request. Please try again later.

Result Code: E_INVALIDARG (0x80070057)
Component: HostUSBDevice
Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

I can't seem to manage to mount it, which is the last step in my plot. Any ideas why this is happening?

share|improve this question
    
Are you connecting the iPad to a USB 3 port? That's not supported in VirtualBox. –  rakslice Feb 7 '13 at 5:52
    
From the error text I'd assume the iPad is being mounted by something. Does it show up as a device on the host? And if so, does ejecting it help? –  Marcus Chan Feb 7 '13 at 6:29
    
It WAS on a USB 3.0 port, but switching to a USB 2.0 didn't help. Same error. And no, I don't currently have it showing up on my PC at all, though opening iTunes, which then mounts it, and ejecting it, doesn't change anything, even after exiting iTunes and iPodHelper. Do you think uninstalling iTunes OR the iPad driver that is likely on my machine will help? –  user196235 Feb 7 '13 at 14:51
1  
Per the EULA you may not run OS X on a virtual machine, unless it's run on Apple hardware through OS X itself. I wouldn't be surprised if VirtualBox didn't support this properly on Windows. –  slhck Feb 7 '13 at 15:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.