Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The Skype client shows a disturbing colored ad at the bottom of the client. The ad is unnecessary and only takes away important space for the contact list.

How can I remove that permanentely?

enter image description here

Even after clicking the close sign on the ad, the ad appears again each time I open/click Skype again...

share|improve this question
2  
Whether it's unnecessary or not is a matter of opinion. Microsoft, not being a charity, might think it's necessary. –  Alan B May 21 '13 at 15:24
2  
Correct, but I'm aware of that Skype can make unlimited* calls or its other features. Microsoft does not need to remind me all the time. Also a Word 2010 does not remind you the whole time that there's a new version or that it can handle automatic reference lists or similar ;-) –  FiveO May 21 '13 at 15:39
3  
No, Word doesn't. Not yet, anyway. But then you paid a whole load of money for Word. You got Skype for free. Ads are how they subsidise giving it you for free. –  Alan B May 21 '13 at 15:52
add comment

5 Answers

up vote 36 down vote accepted

I got rid of this like that. Go to Tools > Options

Skype ver.5.1.32.104

enter image description here

share|improve this answer
3  
This is not enough to hide the advertisements –  Pere May 25 '13 at 11:10
4  
Well, yes, it's not enough. But if you carefully look at the screenshot OP provided, you'll see that he wants to remove promotions, but NOT ads. –  Volodymyr May 25 '13 at 15:49
1  
At least for me, after disabling these 2 options I still see advertisements at the bottom of the client, very similar to the one in the screenshot the OP provided. And after reading the question again, I would say these are the ads the user wanted to remove. –  Pere May 25 '13 at 20:47
3  
It actually worked for me. Just have to sign out and re-login again. Otherwise it's still there. –  wujj123456 Jun 15 '13 at 23:35
1  
Additionaly, if you go to 'Tools' > 'Options' > 'Privacy' > 'Show Advanced Options' in the bottom of the window, you will see something about "Microsoft targeted ads..." I unticked this, and restarted Skype altogether and so long I haven't seen any ads anywhere –  JuanManuel LF Dec 10 '13 at 20:09
add comment

Put this in your hosts file:

127.0.0.1     rad.msn.com

Update: nZeus suggests using the following:

127.0.0.1     rad.msn.com
127.0.0.1     g.msn.com
127.0.0.1     live.rads.msn.com
127.0.0.1     ads1.msn.com
127.0.0.1     static.2mdn.net
127.0.0.1     ads2.msads.net
127.0.0.1     a.ads2.msads.net
127.0.0.1     b.ads2.msads.net
127.0.0.1     ad.doubleclick.net
127.0.0.1     ac3.msn.com
127.0.0.1     ec.atdmt.com
127.0.0.1     msntest.serving-sys.com
127.0.0.1     sO.2mdn.net
127.0.0.1     aka-cdn-ns.adtech.de
127.0.0.1     secure.flashtalking.com
127.0.0.1     cdn.atdmt.com

I haven't tested the latter. The first one worked for me.

share|improve this answer
2  
It's a shame that who downvoted this answer did not even try it –  Pere May 25 '13 at 11:13
2  
Just in case somebody does not know what this does, this makes any attempt to connect to rad.msn.com impossible by making its IP point to localhost. I'm pretty sure it's safe to do, but I don't know if it works (didn't test it). –  Camilo Martin Jun 2 '13 at 3:01
4  
For future reference, location of the hosts file in Windows XP and later (including Windows 8) is %SystemRoot%\system32\drivers\etc\hosts. Just open it in Notepad and add the line in this answer. –  Thunderforge Oct 14 '13 at 17:49
1  
That hostname isn't enough to do anything for me. I put together a list of suggested hostnames to block here: superuser.com/a/708801/130906 –  leetNightshade Jan 29 at 19:23
1  
Please also include this line 127.0.0.1 ad-emea.doubleclick.net Found here. –  Neolisk Mar 9 at 15:08
show 5 more comments

>>Note that the steps below won't work in Skype 6.9 or later<<

To get rid of advertisements upgrade to Skype Premium (from http://www.skype.com/en/premium/):

enter image description here

To disable promotions (from https://support.skype.com/en/faq/FA1111/where-are-alerts-and-messages-displayed):

  1. Click Tools > Options > Notifications.
  2. Select Alerts & messages.
  3. Under Show messages about… tick the boxes for the alerts and messages you wish to receive.
  4. Click Save to update your settings.
share|improve this answer
1  
On OSX (Skype v6.9) there's no comparable option under Preferences/Notifications. –  GingerDog Nov 6 '13 at 10:04
1  
I would like to minus you, but I can't... yet –  nZeus Feb 19 at 20:33
1  
@nZeus Why is that? –  jaume Feb 20 at 13:50
    
Because it doesn't work. See here - community.skype.com/t5/Windows-desktop-client/… Total morons work at Skype support and I'm still fighting. –  CRONUS Mar 17 at 9:15
1  
1) I edited my answer and added that the steps explained won't work in Skype 6.9 or later. 2) I'm sorry to hear that you have trouble getting rid of those ads, but don't take it out on me, the answer was correct at the time of writing one year ago. I don't use Skype anymore, but you do - if you find out how to fix it edit my answer (as explained in Improve posts by editing or commenting in superuser.com/tour) or write your own answer. Thanks! –  jaume Mar 17 at 10:12
add comment

None of the above methods work for the newer versions of Skype A new method has emerged that works in Skype 6.13 and Skype 6.14, works on Windows using Internet Explorer settings, from Chris123NT:

Open up Control Panel > Internet Options.

enter image description here

Security > Restricted Sites > Sites

enter image description here

Type in https://apps.skype.com, and click Add.

enter image description here

Again, click Add, then Close, then OK. Now open up Skype, click on the home button, and the ad banner should disappear and not come back!

share|improve this answer
add comment

The way that works for me (version 6.11.0.102) is the following:

  1. Go to Tools -> Change Language -> Edit Skype Language File...
  2. Navigate to s_LANGUAGE_NAME (line 129 on my English language file)
  3. Change the string to something else that is arbitrary (I use "NoAds")
  4. Click "Save As..." and save the file to what you named it (for me, "NoAds.lang")
  5. Finally, make sure this language is selected as the current language in the Tools -> Change Language menu (if it isn't, use the "Open Skype Language File" option to locate and load it)

From what I remember about this trick... since the ads are targeted towards language, putting in a bogus string value will essentially cause Skype to fail at finding an advert to display, and in turn, it will not display one.

This has worked for me on multiple installs of this same version of Skype, and in versions past as well.

Note: I also do this in tandem with what Volodymyr does in his answer.

share|improve this answer
add comment

protected by Community Jun 10 '13 at 15:02

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.