Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have created 2 new volumes on the SSD (Samsung 840 Pro 256GB) from the previous OS installation before re-installing Windows 8 Pro 64 bit on it.

After installation of: Windows, all the latest drivers from the official Acer site for the laptop (Aspire V3 - 771G), doing a Samsung SSD Magician performance optimization and OS optimization and removing the page file I get these results when running AS SSD Benchmark:

and the benchmark in magician:

which are very low (about half) compared to the results it should return.

I found on Google 2 benchmarks, both having much better performance (closer to expected as in the product specifications):

Things I have checked/tried/are known:

  • connected to a SATA3 port
  • AHCI is enabled in BIOS
  • TRIM is enabled
  • Partition Starting Offset is aligned to a multiple of 4096 for both SSD partitions
  • configured and switched to high performance windows power profile

Any ideas what it could be? Or how to diagnose?

Thanks for your help!

UPDATE 1:

I found the problem by looking in Intel Rapid Storage Technology program - the mode used by the SSD is SATA 2:

Any ideas on how to make it work in SATA 3 mode instead of SATA 2?

I am thinking that it might have something to do with the HDD which cannot work at more than SATA2. Maybe, even though the 2 SATA ports are SATA 3 compatible, the main one in which the HDD is connected is faster, or maybe the HDD is limiting the SDD speed cause it has to use SATA2.

share|improve this question
    
Have you checked the S.M.A.R.T. data to check the wear? Have you performed a secure erase on the drive? Have you updated to the latest firmware? –  Stefan Seidel Feb 7 '13 at 14:38
    
@StefanSeidel: yes, I done a firmware update immediately after installing magician, I have not done a secure erase and the SMART data showed OK on all rows –  Răzvan Panda Feb 7 '13 at 14:53
    
Just OK doesn't mean great. Can you see the total GB written in the SMART data? I mentioned secure erase because that's the one operation that guarantees maximum performance (if benchmarked right after it). –  Stefan Seidel Feb 7 '13 at 14:56
    
@StefanSeidel: this is the data I get from SMART: jsfiddle.net/SUrDV –  Răzvan Panda Feb 7 '13 at 15:01
    
@StefanSeidel: better layout j.mp/WTdpFT –  Răzvan Panda Feb 7 '13 at 15:08

1 Answer 1

Write caching may not be properly enabled and worth going through a few steps to check.

Go to Device Manager

Right-click on your drive then select Properties

Click on the Policies tab.

If Enable write caching on the device is already ticked then un-check it then click ok.

Now retick the box and click ok.

Run your benchmarks again.

share|improve this answer
    
I am getting about the same results after disabling and re-enabling write caching –  Răzvan Panda Feb 7 '13 at 16:55
    
@RăzvanPanda - are you sure you have ahci enabled? it looks like on your benchmark test vs the Fast test sample you provided that iaStorA is - OK, while the Fast sample shows msahci - ok. If this is the issue, I will update my answer. –  Carl B Feb 7 '13 at 20:47
    
Yeah, very sure, AHCI is enabled. iaStorA afauk is an AHCIdriver from intel. I am considering swapping the normal hdd with the sdd ports and doing a secure erase. –  Răzvan Panda Feb 7 '13 at 21:44
    
It seems that the SDD runs in SATA2 mode (question updated). –  Răzvan Panda Feb 7 '13 at 21:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.