Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I'm using remote desktop at work from one specific PC it has a quirk which is really quite irritating.

I'll be typing away and suddenly the Windows key will be pressed, things start minimising, explorer launches, workstation gets locked (but it locks the remote workstation, so I have that wallpaper in the background, rather than the wallpaper from the local machine as I would expect).

I've swapped keyboards, even though it didn't seem to be related to hardware and it made no difference. Done some internet digging and found someone saying it's related to using windows-l to lock the workstation. I've tried to stop myself using that shortcut to see if it helps and have failed miserably :D It's happening to at least one other user remote desktopping from the same machine to a different PC. Reinstalling isn't really an option (I don't admin the PC or I would have tried it, grr), although I could probably get it done if it would definitely resolve the problem.

Any ideas?

share|improve this question
1  
This happens to me ALL the time. Thanks for posting, –  barfoon Jul 16 '09 at 13:39
add comment

10 Answers

up vote 5 down vote accepted

There's a question about a similar problem on technet (subject: Windows Key "stuck"). Details below:

If you are using Win Key + L to lock your desktop, this is a known issue. We have completed work on a fix that should prevent the problem in the future; to my knowledge it is due to be released with Vista SP1.

The bug arises most frequently when you use Win+L to lock your desktop while the Remote Desktop window has focus. It is caused by a synchronization issue between client and server that only arises on a subset of machines, possibly due to a driver or 3rd party software conflict that messes up the timing of the Remote Desktop client. There are a few ways to avoid this:

  1. Don't use Win+L to lock your local desktop. Either lock your machine through the start menu or, if your machine is configured for it, Ctrl-Alt-Del and select Lock Desktop.

  2. Make sure a different window has focus before locking your desktop.

If you have already encountered the problem, the "workaround" is much as you described:

  1. Remove focus from the Remote Desktop window, by selecting another window on your machine, or minimizing and clicking the desktop of the local machine

  2. Strike the Ctrl key 6-12 times. You mentioned the win key which probably works as well, but if you have somehow encountered this error on a machine that doesn't have a Win key, Ctrl should work as well.

  3. Go back to the Remote Desktop window; the problem should be resolved.

Apparently there is a fix in Windows XP Sp3.

share|improve this answer
2  
I got the person that admins the machine to install SP3 and it hasn't done it since, thanks! –  wikiti Aug 7 '09 at 22:31
    
I'm still having this problem on XP SP3. I'm unsure if this problem is caused by Win+L because I do use it occassionally but I haven't noticed a direct correlation. –  HK1 May 16 '11 at 15:11
    
I found that by clicking the windows button on the remote machine (not the local machine) 6-12 times fixes the problem. I'm using windows XP client, and windows 2003 server btw. –  Tom Jun 25 '11 at 16:17
5  
This is not fixed as of 2011/10/19 Windows 7 with all updates. –  Triynko Oct 19 '11 at 16:23
1  
Using updated Windows 7, June 2012. Getting this issue, while remoting into Win7 and Server 2008R2 machines. And I don't even use Win-L to lock –  askvictor Jun 15 '12 at 1:30
add comment

Try this workaround:

  1. Open 'On Screen' keyboard from the Accessories/Accessibility menu
  2. Press the 'On Screen' Windows Key
share|improve this answer
    
I understand this answer to be a way to respond to the problem rather than preventing it. –  Travis Jul 16 '09 at 15:48
1  
but at least this solution does work to resolve the problem after it happens without having to reboot one or both of the machines. –  HK1 Jun 1 '11 at 19:37
add comment

I think I found this happened to me if I locked my computer (using Flag+L) whilst the RDP session had focus. I think RDP stopped the remote computer locking as well in response to this key combination, but "remembered" that the Flag key was pressed, almost as though the key was being held down.

I found a really quick fix was to ensure the RDP session had focus and just hit the Flag key on my keyboard when things started going crazy. This usually fixed it for me.

share|improve this answer
    
What's the syntax to get the button-borders like that? –  Stijn Sanders Jul 16 '09 at 21:45
3  
The <kbd> HTML tag. –  alastairs Jul 17 '09 at 9:05
add comment

This is a Windows Known Compatibility Error, and it will occur each time you Windows-Key Lock your machine. The quickest solution to resolve these crazy function keys being locked is – as @Barfoon recommended – Start → Run → osk (it's the on-screen keyboard utility).

Click the Windows key, and then click it again to disable it.

This resets the error and keys function as normal once again.

share|improve this answer
add comment

One trick I have found to fixing this issue is going to Start --> Run --> osk (its the on-screen keyboard utility), clicking the windows key, and then clicking it again to disable it.

share|improve this answer
add comment

I just had this issue with a machine I was rdp'ing into and various restarts didn't make a difference.

A google search revealed the following fix:

  1. Close the RD window
  2. Open new RD but make sure the "Apply Windows key Combinations" is set on the remote computer.
  3. Now press Ctrl+Alt+End and lock the remote computer.
  4. Log in again and it should work.

I tried this and it worked perfectly.

This fix was found at neowin.net (Subject: Remote Desktop Issue, Sticky Keys Stuck On?)

share|improve this answer
add comment

You can simply go to your Remote Desktop login screen.

ANd press flag+l key

this will lock your current machine. Now go and check it on remote desktop.

My issue got resovled this way.

share|improve this answer
add comment

There is a common issue when using RDP connections and pressing key combinations that invoke special functionality in Windows.

For example, if you press Win+E to open a new Windows Explorer window. The event of pressing down your Win key will be sent through the RDP tunnel. But when you also hit the E, the event is captured by your own desktop and processed accordingly.

That means that the up or release event is never sent through the tunnel, so it will behave as if the key is stuck.

To avoid this from happening, it can be beneficial to simply send all key combinations through to the other computer.

enter image description here

The same flag can also be found in various wrapper applications, like mRemoteNG:

enter image description here

share|improve this answer
add comment

I had this happen to me recently. A quick reboot of the machine solved the problem. That might not be possible in your case, but have you tried it? I haven't had it happen since the reboot.

share|improve this answer
    
I can cure it temporarily by pressing both windows keys a few times, but it's been happening on and off for weeks. –  wikiti Jul 16 '09 at 13:28
add comment

I was connected to RDP and was working on my local desktop,did Windows Key + D is minimize the window. Later when using RDP when i hit D it was minimizing the windows. Went through lot of procedure and did not worked. With RDP highlighted did Windows key + D and it got resolved.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.