Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am experiencing an issue similar to Phantom hard drive after deploying latest Windows 7 image from WDS.

I tried adding the registry value

HKEY_CURRENT_USER\Software\UniPrint\DriveMapping = 0

and then rebooting, but I still have a phantom Z drive showing up. I also tried deleting the Preferred Virtual Drive, but it just came back.

What could be causing this?

share|improve this question
    
here is the fix from uniprint, communities.uniprint.net/forum/viewtopic.php?f=9&t=1098. Windows Registry Editor Version 5.00 [HKEY_CURRENT_USER\Software\UniPrint\Client] "DisableVirtualDrive"=dword:00000001 –  user1249998 Feb 7 '13 at 20:01

1 Answer 1

I'm not familiar with that tool, but you can try using this DriveCleanup tool to remove the phantom drive.

It's able to remove virtual drives I've created with Daemon Tools, so it might do the job for you.

DriveCleanup removes all currently non present "Storage Volumes", "Disk", "CDROM", "Floppy" USB drives and their USB devices from the device tree. Furthermore it removes orphaned registry items related to these device types. Since V0.8 it removes WPD devices under Vista and Win7.

Started with parameter -T (like test) it shows which devices it would remove.

DriveCleanup -T

Started without a parameter, it does its job without further inquiry. To remove certain types of devices there are the parameters -U -D -C -F -V -W and -R.

Sample to remove abandoned registry entries only: drivecleanup -R

Under x64 editions of Windows only the included x64 version works correctly, with the Win32 version you will see "severity error 0x235", which is ERROR_IN_WOW64.

Admin privileges required.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.