Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using zsh with oh-my-zsh as default shell. When I run a command in guake / gnome-terminal / konsole, a string with format (special-char|command-name|%) appears as the first line of output in console. I remember that I ran print -Pn "\e]2;$2:q\a" in console and got this problem after that.

How can I fix this case?

Terminal

Thanks.

share|improve this question

migrated from stackoverflow.com Feb 7 '13 at 19:02

This question came from our site for professional and enthusiast programmers.

1 Answer 1

Close and reopen your shell. A similiar thing happens with PuTTy if you accidentally cat a binary.

share|improve this answer
    
I have tried to close and reopen shell even I have removed and reinstalled zsh and oh-my-zsh but the problem is still here. –  phongnh Feb 8 '13 at 4:10
    
What does your PROMPT variable say? It probably has something weird in it if this persists across closing the shell. This guy had a good reference: nparikh.org/unix/prompt.php and so did this guy: stevelosh.com/blog/2010/02/my-extravagant-zsh-prompt –  kmort Feb 8 '13 at 14:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.