Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to set up an ad-hoc network at my dad's place. He has a desktop machine into which I have installed a wireless card, and a new laptop with built-in wireless. There is no router, so I want the two machines to be in an ad-hoc network. The desktop machine is set up to dial out to the internet, so ideally I'd like that to happen automatically when either machine tries to access the internet, but for now I'm just trying to get basic file/printer sharing going.

Both machines are running XP SP 3, and neither is reporting problems with the wireless cards. I know the laptop works because I set it up at my place and it was fine. I ran through a wireless networking wizard (several times) which had me insert a thumbdrive into the desktop and then the laptop. The laptop then said that it had successfully joined the network, but the machines still couldn't seem to see each other. But I am unable to diagnose why not - everything seems to succeed except that the machines can't see each other. The machines are currently two feet apart.

If I set up the network on the desktop and then go to "display wireless networks" on the laptop, it shows nothing. If I manually add the network SSID and such into the laptop, it claims to see it, but refuses to connect to it. The only error message I get is "cannot connect".

I don't know if the card I installed is simply not working (it worked last time I tried it but it's been sitting in a closet for a while - Windows is not reporting any problems with it), or if there is some kind of authentication problem somewhere, or something else. I'm not seeing any error messages, it's just not working and I don't know how to diagnose why.

share|improve this question
add comment

1 Answer 1

Sounds like the wireless adapter on the desktop has not been fully configured for Ad-Hoc mode. The default configuration is called infrastructure mode, which your adapter is likely still operating at. See this detailed guide for more information.

share|improve this answer
    
I don't think so because the desktop says that it's connected to the network. There is no router so the network it's referring to must be the ad-hoc network it's created. I've made sure to select ad-hoc mode. Thanks for the link though - I did not set up static IP addresses or netmasks so perhaps that's the problem. –  Graeme Perrow Oct 13 '09 at 15:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.