Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Rather than pester the very helpful Scott Chamberlain in the comments to this question, I'm moving my issue here.

I'm developing a web app on my work computer (Windows 7), and I've gotten a bug report complaining of bad behavior on the Mac version of Firefox. We don't have a Mac in-house, so I brought in my personal laptop. The trouble is, I can't get it to connect to my work machine.

Both machines are on the local wi-fi network. The work machine has access to a VPN that my personal laptop does not. Any time I try to access 192.168.1.4:8080 (the IPv4 address assigned by the wireless network) from my personal machine's browser, I get nothing. I also get nothing when I ping 192.168.1.4.

My first thought was that it's a firewall issue; I don't have the permissions necessary to simply disable it. I've tried poking holes via "Windows Firewall with Advanced Security" (allow incoming access on port 8080, allow incoming access for all programs), but it doesn't seem to be doing anything.

It also occurred to me that my work machine might be invisible on the network. I've tried turning on file sharing and network discovery via "Advanced sharing settings", but that hasn't worked either.

I'm still poking around with rsop.msc as Scott recommended in my other question, but as I've never used the tool before, I'm not completely certain of what I'm looking for. I'm hoping something will jump out at me as I keep digging.

In the meanwhile, what other approaches would people recommend?


Edit: In response to the comments, I double-checked to confirm the Mac is on the same network. It is; it has an IP address of 192.168.1.7, and I can ping it from the work machine.


Edit 2: I suspect that, unless I can track down a sysadmin willing to relax the settings on my machine, I'm simply screwed.

I presumed that, since they're on the same network, the Mac would subject to the "Domain Profile," but more research tells me it's more likely under the purview of "Private Profile." Is that a reasonable conclusion?

The difference is that the Domain overview says "Inbound connections that do not match a rule are blocked", whereas the Private overview says "All inbound connections are blocked". If I'm interpreting this correctly, then any holes I try to poke in the firewall are useless, since they run afoul of this higher-level rule. This would explain the behavior I'm seeing; I can see the Mac from the Windows machine but not vice-versa.

If anybody has any insights that confirm or refute this theory, I'd love to hear them. In the meanwhile, I'm sending "Could I please speak with a sysadmin?" messages to the helpdesk.

share|improve this question
    
Port 8080 is often used for proxies. Are there any proxy settings you need to add to your Mac? –  techturtle Feb 8 '13 at 19:21
    
@techturtle: Under Network -> Proxies, I'm not seeing any proxy settings defined. –  BlairHippo Feb 8 '13 at 19:25
    
Is this VPN connection active at your work machine while you are trying to reach it and what tool is used to establish the VPN? –  Serge Feb 8 '13 at 19:42
    
I've tried reaching it with the VPN on and off; doesn't seem to make a difference. I'm using Cisco Systems VPN Client Version 5.0.07.0440. –  BlairHippo Feb 8 '13 at 19:44
2  
Then this is strange indeed. –  Serge Feb 8 '13 at 21:01

3 Answers 3

up vote 1 down vote accepted
+50

I'd contact your systems administrator at your work and see if they already have something for this occasion. This also keeps things above board and within your corporate security and policies for access.

share|improve this answer
    
Trying; I'm going through the help desk. Thus far, the responses have boiled down to "Yeah, that should be working!" I'm not looking for sneaky hacks here, I just want to figure out why it isn't working. :-) –  BlairHippo Feb 8 '13 at 20:42
    
Of course, it doesn't help that I'm at a very remote, very small office; I can't track down the sysadmin at his/her cubicle and beg for assistance. I asked my supervisor for help, only to be told that he couldn't get anything like that working, either -- and if I figure it out, I need to share. –  BlairHippo Feb 8 '13 at 20:44
1  
Well at least you have protected yourself. I've seen such things result in abrupt termination and I'd hate for that to happen for you. –  mdpc Feb 8 '13 at 20:45
    
Yup yup. I asked my boss for permission before I even brought my personal machine through the door. I'd hate for that to happen to me, too. –  BlairHippo Feb 8 '13 at 20:48
    
Unsatisfying though it is, given than IT is being glacially slow helping out, I'm pretty sure this is the correct answer. I simply don't have the permissions I need to punch holes in the firewall that my Mac can use. –  BlairHippo Feb 20 '13 at 13:30

I don't understand the 8080 port : WiFi doesn't assign ports, only IP address.

One idea: If the VPN permits it, you could maybe Share the Internet Through an Ethernet Cable From Your PC to Your Mac. This way you create your own network which is not under the control of your network administrator.

Turn off any firewall on the Mac just in case.

share|improve this answer
    
The 8080 port is configured by the glassfish server; when I access 8080, I'm using Firefox, not ping. And it looks like the Mac firewall is already turned off. –  BlairHippo Feb 12 '13 at 20:08
    
Let me know if the Ethernet idea is workable in your setup. –  harrymc Feb 13 '13 at 8:41
    
The direct Ethernet cable doesn't seem to be doing anything. On Windows, I see an "Unidentified network" show up on the Network and Sharing Center, but I still can't ping the Windows box from the Mac, nor can I access it via HTTP. Is there something I need to configure on the Windows side? –  BlairHippo Feb 13 '13 at 15:37
    
The article above was supposed to tell how. –  harrymc Feb 13 '13 at 18:24

Obviously there are only two possible issues here:

  1. Your Windows 7 PC has it's firewall turned on (very likely) and you will need to allow the port through the Windows firewall
  2. Your Application Server could be bound to localhost or 127.0.0.1 only and in this case you'll need to change it to listen to 0.0.0.0

You can verify (2) by either

  • test if 192.168.1.4:8080 responds on your work machine (sometimes it's a habit to just use localhost:8080)
  • much better: open a command prompt (Win+R, type cmd) and run netstat -nap TCP - you should see at least one line where under "Local Address" you have "something:8080" and under "State" "LISTENING" - if something is not 0.0.0.0 or 192.168.1.4, then the IP binding is your primary problem.

P.S.: Under Windows, repsones to ICMP packets are by default turned off, so your ping from the Mac won't work even with the firewall turned off. The fact that you can ping the other way means that it's not a network issue at all.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.