Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After reading Does All LAN Traffic Travel Through A Router as well as my previous experience, I'm surprised that traffic between two Mac computers on a Gigabit 5-port switch (Netgear Model GS105) was so extremely slow.

Both Macs (Mac mini 2009, iMac Late 2009) connect to a Router (Netgear WNDR4700) via the Switch, but since the cable between Switch and Router is 30 meters long (and perhaps the cable not being specified for Gigabit) the connection to the router has always been only 100 Mbit/s.

If I transfer files between the two Macs, I get around 3-4 MB/s - which seems to indicate that the traffic goes all the way to the router before taking the same route back. Both Macs ought to be able to connect to each other via Gigabit.

I also noticed that unplugging the router cable from the switch does not just disconnect me from the Internet, it also disconnects the two Macs - they can't see each other anymore. Even if I configure IPv4 manually (but retaining 192.168.1.1 as Router & DNS address).

What could be the reasons why I can't connect the two Macs directly respectively why is traffic going through the router? Is my switch defective? Is it perhaps not a switch but a hub (it has "Gigabit Switch" printed on it, and is advertised as switch)? Is there any way I can confirm that traffic is actually routed through the router, or merely slowed down by cables & switch connecting the two Macs? Anything else that could be incorrectly setup here, or things I should try?

share|improve this question
    
Have you tried making a traceroute to see how the packets travel? –  AAlvz Feb 9 '13 at 0:58
    
yes, but I only get asterisks for all hops. I also found out that one of the network cables was faulty and connected only at 100 Mbit/s. After exchanging it file transfer speed went up, though time machine from one mac to the other mac's shared drive is still very slow. –  LearnCocos2D Feb 9 '13 at 1:14
2  
aaah … interesting: one Mac to the other is all asterisks, vice versa it's a single hop as it should be. Checking firewall… yes, the target computer had its firewall enabled (from wayyyy back when). –  LearnCocos2D Feb 9 '13 at 1:17
1  
Ok, so file transfer speed is still below < 40 MB/s after changing cables (though ok, might be limited by the R/W speed of the 2.5" disks), but Time Machine is still extremely slow over the network. I'll look into that, perhaps its a TimeMachine specific issue. With the new cable at least I can see clearly on the switch's ports that by far most traffic is switched directly, because the router's port blinks less frequently. –  LearnCocos2D Feb 9 '13 at 1:28
1  
I know that. I'm thinking Megabytes, not Megabits. –  LearnCocos2D Feb 9 '13 at 1:48

1 Answer 1

up vote 1 down vote accepted

I think your hypothesis is incorrect, and the packets are most likely not going through your router. Have you tried a cable directly between you 2 macs (along with static IP addressing) and see what that does ? This might help answer questions arround "why the macs don't speak to each other), ie point out if it is a problem on the macs or the infrastructure between them.

I suspect part of your problem might be dodgy cabling.

When 2 devices are on the same subnet they do not go through a router (at least not the kind of routers you are using). What happens is an ARP request is made on the Interface broadcasting a "where are you" to all machines on the subnet, and the machine which has the IP you are looking to connect to should answer with its MAC address. The sending machine then updates its ARP cache and knows to send further traffic directly to that machine - no router involved.

You can check if this is happening by pinging from one PC to the other and checking the arp caches to see if they record the MAC and IP addresses of the other PC. If not, it will help narrow down what is going on. To do this (on a POSIX compliant platform, I'm guessing it will work on a mac, simply type "arp -an" on the command line.

share|improve this answer
    
Yes, my assumptions were incorrect. A number of things happened, including a faulty cable, mistaking which cable goes where, the firewall being enabled on one computer, and a faulty backup disk. –  LearnCocos2D Feb 9 '13 at 11:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.