Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some reason my laptop has a mind of its own and the Caps Lock tends to come on whenever it feels like it. I thought it was an software issue from that reasoning, but I later cleared the OS and then reinstalled it hoping to fix the problem, but it didn't. Not only does it do that it also comes on and off whenever the letters A, S, and left shift key are pushed.

So I assummed it was a keyboard issue and that the keyboard needs to be replaced, but it has one of those touch pad cap lock buttons also, because even when I press that button it tends to not react. So how can that be fixed with a keyboard replacement or is that connected still?

EDIT - I followed the direction with the following code in notepad and it didn't do the job:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
“Scancode Map”=hex:00000000 00000000 0200000000 00003A00 00000000
share|improve this question
    
A laptop model number and maybe some pictures would help this question greatly. –  Troggy Oct 13 '09 at 15:57
add comment

2 Answers 2

Actually, if the CAPSLOCK key is entirely useless to you, instead of spending hard-earned money trying to repair the notebook, why not just disable the CAPS key entirely? :)

Check this page out for how to do so...

EDIT For some reasons (it worked when I tested it), the registry codes at the top does not seem to work for people. Recommending another solution - this time an application.

CAPS UnLock - Allows systems to disable Caps Lock and Insert keys.

share|improve this answer
    
This looks like a GREAT idea for my fat fingers. Will it work on XP and where is it? –  Xavierjazz Oct 13 '09 at 16:10
1  
@Xavierjazz : Mate, here ya go. :) mydigitallife.info/2009/01/04/… –  caliban Oct 13 '09 at 16:19
    
although this solution might work, which I will try when I get to my computer, I still would like to know what kind of issue was it in case I ever decided to fix it the right way –  Mr New Oct 13 '09 at 16:44
    
@caliban - Thanks –  Xavierjazz Oct 13 '09 at 16:50
    
tried it and it didnt disable..i already restarted it –  Mr New Oct 14 '09 at 0:59
show 3 more comments
up vote 3 down vote accepted

Caliban your approach worked pefectly, but the link you gave me solution wasnt disabling it for me, but This solution from vistax64.com worked, it was a little different but did the job: Disable the Caps Lock Key

share|improve this answer
    
+1 - This worked for me. Thanks. –  Xavierjazz Oct 15 '09 at 1:28
1  
Glad it worked for you. :) +1 mark your own answer as the answer! –  caliban Oct 15 '09 at 3:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.