Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Windows 7 on my laptop, and now the 3D doesn't work. According to dxdiag DirectX 11 is installed, but when I open up World of Warcraft, this error comes up.

World of Warcraft

World of Warcraft was unable to start up 3D acceleration. Please make sure
DirectX 9.0c is installed and your video drivers are up-to-date.

There are no alerts from Windows to update any drivers. Why doesn't the 3D work?

share|improve this question
This is not much of an answer (hence the comments section). It's a long shot, but could this possibly be a virus issue? Have you tried running a scan? – Yuval May 18 '10 at 8:15

If its a stock r51 (as opposed to say an r51p which might be a little better), it could be that the video card is just too old - even if DX11 is installed, it has a intel integrated graphics card with 12 mb of vram. The ATI models have 32 mb of vram, which is still just not enough by modern standards.

You're just expecting too much of the old girl- I don't think the video cards support most of the newer features required of dx9 either.

share|improve this answer

IF you haven't updated the graphics drivers to those provided by the graphics card manufacturer ( nVidia/ATi ) , please do so. Also try updating to August 2009 edition of DirectX 9.0c

share|improve this answer

One thing that springs to mind is that WoW is checking for the exact version of DirectX rather than it being greater than or equal to 9.0c, though it seems unlikely (it used to be a big problem). It might be worth eliminating this as a possibility.

Do you have any other 3D applications or games you can run to test to see if they work or not? There are some test/demo applications that come with the DirectX SDK, so you could try those.

If they do then it's a WoW issue.

If they don't then it's a general problem.

share|improve this answer
I just tried a few other games, and none of them work. For example, "Dawn of War: Dark Crusade" brought up an error: "Failed to initialize video card." It seems like a driver issue, but Windows doesn't see any driver updates. – John W. Oct 13 '09 at 16:09

Windows may not see any driver updates, however there may be some on the Thinkpad support site. I know with my Dell laptops they provided updated video drivers for the Latitude series laptops that windows update doesn't see. I believe ATI also has mobile drivers on their website for certain mobile video chip sets which may work if your using an ATI graphics chip set on your laptop.

Good Luck!

share|improve this answer

Check to ensure 3d acceleration is set to full under Display Properties ( Screen Resolution -> Advanced Settings, I believe).

share|improve this answer

Some games require DirectX 9.0c, which isn't a problem, as it can be installed on the same machine in parallel with DirectX 11.

You may download DirectX 9.0c from Microsoft here, but your best bet is to find its installation on the WoW DVD. This is because Microsoft may not install all the DLLs required for gaming.

share|improve this answer

It looks to me that if you have the bog standard R51 with Intel graphics then the system may only support DirectX 8.

If this is the case and WoW actually requires DirectX 9 features and will not work without them then there is no way it will work on your system.

Here is some information on the Intel Graphics chip you may have:

The ATi chips do not fare much better but may work a little better.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.