Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to completely reinstall X server and AMD proprietary drivers on a Fedora Core 17 amd64 with kernel 3.6.11.

How do I make sure nothing of my previous setup / configuration remains, so that I could attempt a whole new fresh install of X server? So far I tried uninstalling X.org and whatever packages that contains x11 or xorg in it., searching the system for files having "xorg" string in them and methodically removing these. I've tried to rebuild initramfs.

But after all this, if I run the proprietary catalyst driver downloaded from AMD site it tells me that it had detected the previous setup...

I've tried following two different walk-throughs on setting up the drivers. First one was for building the kernel module, second one was for running the installer downloaded from AMD - there were minor changes in the ways of how the system failed to boot as the result. Still, the system does not boot. I've tried to replace "fglrx" with "vesa" in the xorg.conf - no change (I don't know how to make the system try to boot with vesa drivers only, but even if I could, I still need it to boot with some sort of GL available).

Now, the funny part: I'm doing this because I've taken a course on GL programming...

This is what I get from lspci -v on an ancient Ubuntu, which is also installed on the same PC:

03:00.0 VGA compatible controller: ATI Technologies Inc Device 6819
    Subsystem: Giga-byte Technology Device 2553
    Flags: bus master, fast devsel, latency 0, IRQ 33
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    Memory at fb780000 (64-bit, non-prefetchable) [size=256K]
    I/O ports at de00 [size=256]
    [virtual] Expansion ROM at fb700000 [disabled] [size=128K]
    Capabilities: [48] Vendor Specific Information <?>
    Capabilities: [50] Power Management version 3
    Capabilities: [58] Express Legacy Endpoint, MSI 00
    Capabilities: [a0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
    Capabilities: [100] Vendor Specific Information <?>
    Capabilities: [150] Advanced Error Reporting <?>
    Capabilities: [270] #19
    Capabilities: [2b0] #0f
    Capabilities: [2c0] #13
    Capabilities: [2d0] #1b
    Kernel driver in use: fglrx_pci
    Kernel modules: fglrx

Also, this: http://unix.stackexchange.com/questions/50784/fedora-17-freezes-on-boot seems to be very similar to the problem I'm having (Plymouth fails for me too). I still need to try to disable it. This appears to be irrelevant. After disabling Plymouth, I'm finally getting an error in Xorg log, which is about swlPPLibNotifyEventToPPLib...

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.