Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having some issues installing windows update on this particular Windows 7 PC. I'm trying to (for instance) install Service Pack 1, and its popping up an error saying "Element Not Found", and then marking it as failed with Error Code 490 : "Encountered an Unknown Error" (very useful).

This happens to pretty much all windows updates I've been trying to install.

So far, things I've tried:

Virus Scan

  • Virus Scan
  • Error Scan
  • Running two different Microsoft 'ifixit' related to windows update
  • Running it in safe mode
  • Running the SP1 preperation tool
  • Downloading SP 1 manually and running that
  • Restarting
  • Force shutting it down, taking out the battery and turning it on again

This problem has been ongoing for months now.

Looking at the System logs I do see a lot of errors but they aren't giving any useful information "Not avaliable"

So far nothing has worked, anything else I could try? I can't format the PC unfortunately.

share|improve this question
    
Just curious, why can't you reformat? Have you tried force-shutting down (hold power button for a few seconds) and rebooting? –  danielcg Feb 9 '13 at 16:26
1  
Because its not my machine and the owner doesn't want it to be reformatted. I have tried shutting down, restarting and pulling the battery out and the rest. –  Haedrian Feb 9 '13 at 16:29
    
Try looking at the event logs for any useful information. –  danielcg Feb 9 '13 at 16:35
1  
I looked at the error logs, there are a number of WindowsUpdateFailure with details "Not available". Not helpful. –  Haedrian Feb 9 '13 at 16:42
    
Did you reset the date/time when you replaced the battery (If this is a PC/not laptop)? This would eliminate a potential issue with date (year) conflict. –  Carl B Feb 12 '13 at 4:12

2 Answers 2

Open an elevated command prompt and enter the following. Press enter at the end of each line.

 net stop wuauserv
 regsvr32 wuapi.dll
 regsvr32 wuaueng.dll
 regsvr32 wucltux.dll
 regsvr32 wudriver.dll
 regsvr32 wups2.dll
 regsvr32 wups.dll
 regsvr32 wuwebv.dll
 net start wuauserv
 exit

After all that, reboot.

share|improve this answer
1  
Hmm, comments seem to have disappeared. I ran MBAM and it found nothing. Meanwhile on restart it succeeded in installing around 60 upgrades, just 11 to go or so with this problem. –  Haedrian Feb 10 '13 at 11:26
    
Very weird. Maybe ask a friend with the same OS for his .DLL that is missing on yours? –  danielcg Feb 10 '13 at 21:26
    
I think the comments disappeared due to the server move yesterday. –  danielcg Feb 10 '13 at 21:26

Repair Windows 7 with the inplace ugrade

  • boot into Windows
  • insert the Windows DVD
  • run the setup.exe
  • select upgrade instead of clean install.

and try to install the Sp1 again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.