Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've tried switching to Mint (it was Mint 12) about 6 months ago, but failed to do it due to enormous overheating which made it virtually impossible to run any applications more complex than Gedit.

Time had passed, and now I'm back again with Mint 14, but feeling way more determined.

What I face are the following issues:

1) Great overheating (and by great I mean that just by doing nothing my CPU temp is floating around 70-75 C, which I find a lot)

2) Running multiple applications (let's say Chrome, Skype and Pidgin) results in critical overheating and immediate shutdown of the system

3) Due to the stuff listed above, my battery drains in about 10-15 minutes, pretty much turning my laptop into a crippled desktop machine

I've got a HP-dv6 laptop (i7, 6gb RAM, dual graphics)

Here's the output of lspci:

        00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM   Controller (rev 09)
        00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
        00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
        00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
        00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
        00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
        00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
        00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
        00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
        00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
        00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
        00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 05)
        00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
        00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
        01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Whistler XT [AMD Radeon HD 6700M Series]
        07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express  Gigabit Ethernet controller (rev 06)
        0d:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
        13:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card      Reader (rev 01)
        19:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)

what i've tried to do already:

1) I've edited my grub file to add some "splash" arguments there

2) Installed jupiter and powertop

3) Tried to upgrade to newer kernels (up to 3.8), btw running anything newer than 3.5 results in both resolution and wi-fi detection fail

4) Read lots of forum threads devoted to the topic

So, my question is simple:

What else might I do to become finally able to use Mint as my default OS without the risk of being burned alive by the CPU heat?

share|improve this question
2  
I guess the fans don't work right? Can you hear them spinning when you turn the laptop on? I also assume you do not have this problem with other OSs. Which have you tried? Windows? Another Linux distro? Does the same problem occur if you run a live session off of the Mint CD? –  terdon Feb 9 '13 at 16:32
    
yes, I do. also, i've disassembled the laptop and cleaned everything i could, even renewed the thermopaste, moreover while running Windows i don't experience any cooling problems. –  agvares Feb 9 '13 at 16:39

3 Answers 3

Try the following things:

  • Make sure your fan is set to "Performance" or equivalent (not "Quiet" in any case) in the BIOS.

  • While you're there, deactivate the dedicated graphics card, it is a major source of heat. If you do this, you may need to modify your xorg.conf and remove any nvidia drivers you have installed.

  • Try managing your fans.

    sudo apt-get install lm-sensors
    sudo sensors-detect
    

    Answer "y" to all questions and load any modules suggested by the last step using (sudo modprobe module_name), make sure the settings are loaded and then then run sensors:

    sudo sensors
    sudo sensors 
    

    Is a fan speed reported?

  • Try pwmconfig

    sudo  pwmconfig
    

    This should briefly deactivate each of your fans and then try it at full speed. Make sure the fans are spinning again after this step. If that works you're set. Follow the instructions here to make it permanent (careful, they might be out out of date but the principle should be the same).

  • Is your CPU always running at top speed? Try setting another scaling governor. Your options are:

    • Performance keeps the CPU at the highest possible frequency
    • Powersave keeps the CPU at the lowest possible frequency
    • Userspace exports the available frequency information to the user level (through the /sys file system) and permits user-space control of the CPU frequency
    • Ondemand scales the CPU frequencies according to the CPU usage (like does the userspace frequency scaling daemons, but in kernel)
    • Conservative acts like the ondemand but increases frequency step by step

Personally, I use ondemand and recommend it. The Ubuntu wiki warns of certain problems, but I have never had any trouble with it. To use the ondemand governor do:

sudo sh -c "echo ondemand >  /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor"
share|improve this answer
1  
The BIOS settings shouldn't make a difference if another OS works without overheating. –  vonbrand Feb 9 '13 at 22:50
    
@vonbrand you never know. In any case it won't hurt and it might help. –  terdon Feb 9 '13 at 22:58

It sounds like your fans aren't working. If it works fine in other OSes, it's likely a driver issue. You'll need some cooling to use this answer. Open the machine up and find the fan. Figure out the voltage it takes, and connect it to that voltage. If it's a smart fan (not controlled by input voltage) then this will not work. If it's not, this should spin the fan at it's maximum speed.

Usually fans are controlled by the motherboard, so find the correct drivers using another machine, wget them on your overheating machine, and try to install them on your overheating machine. Don't try this without the fan running.

share|improve this answer
2  
Woah there! There are a few things to try before opening the machine up. Lets see if it works in a Live session first. –  terdon Feb 9 '13 at 16:36
    
The only thing that would rule out is a hardware failure. I'm assuming OP has another OS that he uses, maybe that wasn't a very good thing to assume. –  danielcg Feb 9 '13 at 16:38
    
The live session could load various modules by default that are absent in the actual install. If the fans work in the live session, we could figure out which modules those are. –  terdon Feb 9 '13 at 16:43
    
@terdon, you are right there. But OP told that (s)he had cleaned it out, and replaced the thermal paste already. –  vonbrand Feb 9 '13 at 22:49
    
@vonbrand I know, that's why I wouldn't open it yet. My guess is that it can be solved by loading the appropriate fan control modules. –  terdon Feb 9 '13 at 22:56

I also have a HP-DV6, I7 but with 8GB RAM. And Mint 14. I had a huge problem with heat (fans running flat out etc etc). After a bunch of searching the following link gave me a solution that works a treat. I can hear myself think again.

http://techhamlet.com/2012/05/ubuntu-how-to-fix-over-heating-of-laptops-with-switchable-graphics/

share|improve this answer
1  
Please don't just paste the solution that you have found on other pages but explain the solution in your post and refer to the URL for referances and deeper explanations. Cheers. –  Mogget Apr 13 '13 at 16:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.