Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got Fedora 18 and Windows 7 installed on the same machine, and I want to change Default boot time from 3sec to 7sec also and the default start-up systems windows 7. I have used this commande :

gedit /etc/default/grub And I have edited the file like this :

    GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=”Windows 7 (loader) on /dev/sda1″
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap nomodeset rd.md=0 rd.dm=0 $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) vconsole.keymap=fr rd.luks=0 rd.lvm.lv=fedora/root rhgb quiet"
GRUB_DISABLE_RECOVERY="true"
GRUB_THEME="/boot/grub2/themes/system/theme.txt"

But it hasn't worked. Any one tell me what's the problem?

share|improve this question
    
What does "it hasn't worked" mean? What hapens when you boot? Also, your timeout is set at 10, not 7 (typo?), and make sure you use simple double quotes ", you have in your question. –  terdon Feb 10 '13 at 16:47
    
That's mean My Timeout still at 3sec not 10sec like how I configured and the system boot on fedora by default. –  Chlebta Feb 10 '13 at 17:00
add comment

1 Answer

up vote 0 down vote accepted

EDIT: It seems that Fedora 18 uses a modified version of GRUB. I have no experience with this (I recommend you read the linked page) but this should work:

grub2-mkconfig -o /boot/grub2/grub.cfg
grub2-install /dev/sda

After making changes to /etc/default/grub you need to regenerate the grub configuration file and then re-write grub to your MBR. Assuming your grub is installed on the MBR of your primary hard drive, do this after editing the file (as root):

update-grub
grub-install /dev/sda

Change /dev/sda to the appropriate location if that is not where you have installed grub.

share|improve this answer
    
update-grub is unknown commande when I try it. –  Chlebta Feb 10 '13 at 17:05
    
Are you running it as root? If yes, also try specifying the full path (see updated answer). –  terdon Feb 10 '13 at 17:09
    
Yes I'm logged as root and update-grub is unknow –  Chlebta Feb 10 '13 at 17:25
    
@Chlebta see my updated answer and this page. –  terdon Feb 10 '13 at 17:35
    
Thank's a lot :) and Sorry I dont have enough reputation to vote up :/ –  Chlebta Feb 10 '13 at 20:56
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.