Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having a interesting problem a followed a guide to setup mamp all seperately on my local machine from this site Heres the hitch at one point we setup local host when I visit localhost/~anderskitson it takes me to my sites directory now what port is that? since Local tunnel which I am trying to use requires the port I am on.

How do I figure out what port I am on since its not in the url?

Here are the steps I followed to set this up

cd /etc/apache2/users

Added

<Directory "/Users/username/Sites/">
Options Indexes MultiViews
AllowOverride All
Order allow,deny
Allow from all
</Directory>

UPDATE

I run the following command in terminal

localtunnel -k ~/.ssh/id_rsa.pub 80

but I get the following

/usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in `to_specs': Could not find localtunnel (>= 0) amongst [actionmailer-3.2.8, actionpack-3.2.8, activemodel-3.2.8, activerecord-3.2.8, activeresource-3.2.8, activesupport-3.2.8, appscrolls-0.8.4, arel-3.0.2, builder-3.0.4, builder-3.0.0, bundler-1.1.5, coffee-rails-3.2.2, coffee-script-2.2.0, coffee-script-source-1.4.0, coffee-script-source-1.3.3, colorize-0.5.8, erubis-2.7.0, execjs-1.4.0, hike-1.2.1, i18n-0.6.1, i18n-0.6.0, journey-1.0.4, jquery-rails-2.2.0, jquery-rails-2.1.1, json-1.7.6, json-1.7.5, mail-2.4.4, mime-types-1.19, multi_json-1.5.0, multi_json-1.3.6, mysql-2.9.0, polyglot-0.3.3, rack-1.4.4, rack-1.4.1, rack-cache-1.2, rack-ssl-1.3.3, rack-ssl-1.3.2, rack-test-0.6.2, rack-test-0.6.1, rails-3.2.8, railties-3.2.8, rake-10.0.3, rake-0.9.2.2, rdoc-3.12, rubygems-bundler-1.0.7, rubygems-update-1.8.25, rvm-1.11.3.5, sass-3.2.5, sass-3.2.1, sass-rails-3.2.6, sass-rails-3.2.5, sprockets-2.1.3, sqlite3-1.3.7, sqlite3-1.3.6, thor-0.17.0, thor-0.16.0, tilt-1.3.3, treetop-1.4.12, treetop-1.4.10, tzinfo-0.3.35, tzinfo-0.3.33, uglifier-1.3.0, uglifier-1.2.7] (Gem::LoadError)
    from /usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:256:in `to_spec'
    from /usr/local/rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems.rb:1231:in `gem'
    from /usr/local/rvm/rubies/ruby-1.9.3-p194/bin/localtunnel:22:in `<main>'
share|improve this question

Unless you tell it otherwise (and you haven't), Apache listens on port 80.

Although I have a suspicion you mean something else, your question is a bit vague.

share|improve this answer
    
that was what I was looking for, but it still is not working, I updated my question with the error output I am getting in terminal. – Anders Feb 10 '13 at 17:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .