Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having a lot of problems with my NAS and my router which I can't find the cause of.

My setup: Synology DS213 with DSM 4.1, Netgear CG3100, two computers running Windows 8 Pro 64-bit

Everything worked fine until one day when the CloudStation-synch-app stopped working on both computers (connection error). I also noticed I can't connect to the NAS-admin-gui with my * anymore (using IP works) even though the DDNS-service is activated and seem to work according to the NAS. In control panel -> router config of my DS I allready have some port forwards but now I can't remove or add anything with the respons: "Connection failed. Check network settings".

Internet works on all computer and the NAS is connected to internet too.

The only thing I can remember I have done before this happened is to setup NFS for XBMC and also activating SSH and SFTP. But I have tried turning this off again and that did'nt do it.

Any suggestions? I can still access files on the NAS over network and I have internet-access. But it's annoying that I can't get CloudStation to work and I'm also having problem getting VNC to work (don't know if it's related). And I can't access the NAS-gui with my * with is also annoying. I'd really like to get this working again. Without factory resetting both my router and NAS.


This is what I get when checking logs with "tail /var/log/messages":

When trying to save a port forward change in router config:

Jul 2 22:15:26 routerconf.cgi: lib/crypt.c:50 Failed to open source file.(No such file or directory)
Jul 2 22:15:26 routerconf.cgi: lib/routerdb.c:289 load router desc failed
Jul 2 22:15:26 routerconf.cgi: routerconf.cpp:624 failed to get router description

When trying to "set up router" in router config:

Jul 2 22:16:40 routerconf.cgi: (upnpclient.c:1571) clean up finished
Jul 2 22:16:40 routerconf.cgi: routerconf.cpp:339 init UPnP faild

I don't know if this is messages I got before when it was working as well but I doubt it. When checking crypt.c row 50 it seem to be crypt.h that is not found (?). And according to the last log-error "init UPnP faild" it almost looks like the router hasn't enabled UPnP but I have verified it's activated and I can also see that the NAS has connected with UPnP allright. This is weird. Any help pointing me in the right direction and I will mark it as a solution! I'm desperate!

share|improve this question
up vote 0 down vote accepted

I found a solution now! For some reason, the NAS wasn't able to set port forwarding on the router anymore. And the ones that was allready set previously when it was working was now gone from the router (but still visible in the router config page on the NAS). The only thing I needed to do was to add the same port forwards manually on the routers own setup page and then everything worked again! I mean the services, CloudStation, DDNS etc. I can still not configure the router port forwards via the NAS but that's not important.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.