Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Canon Digital Ixus 990IS. The PC (running Windows XP SP2) sees the camera fine. I can copy images and movies.

However a large movie (900mb) fails with no message. This MS KB article describes the problem in detail. I face "Symptom #2" (as they call it).

The proposed solution is:

You can connect the camera by using USB Mass Storage Class (MSC) instead of PTP. Then, transfer large files by using Windows Explorer.

How do I do this? Any other workarounds?

share|improve this question
    
Are you sure that you face the problem in the KB article? Accoridng to the article "This problem was first corrected in Microsoft Windows XP Service Pack 2", so you shouldn't have any problems. –  user13792 Oct 21 '09 at 15:43
    
@weiqure: the SP2 part is for Symptom #1, which is a problem with the PTP driver supplied by Microsoft. Since SP2 fixes the problem, presumably they upgraded the driver in SP2. –  Jared Harley Oct 21 '09 at 15:47
add comment

8 Answers

up vote 3 down vote accepted
+50

I believe the Canon Ixus 990IS defaults to PTP mode (At least my Ixus 970IS seems to). There doesn't appear to be a way to change this either.

It may be worth using a card reader to transfer the files, if you have access to one.

You might also find a more informed answer on one of the sister sites dedicated to photography, such as photography.angle

share|improve this answer
    
External SD card readers will mount your card in Mass Storage mode, getting around the problem you're experiencing. USB SD card (or the 9-in-1 or even 17-in-1!) readers are cheap and easy to come by: newegg.com/Product/…-20-134-548--Product –  Jared Harley Oct 21 '09 at 15:52
add comment

I've had the same issue with an MP3 player. The solution was the same, also (change the device to MSC).

However, this is a setting that is set on the device, not your computer. If your device doesn't have this setting, you are forced to use other suggestions such as use a card reader to mount it as a drive, etc.

share|improve this answer
add comment

Two suggestions:

  1. Are you connecting to USB via hub or monitor? Try plugging in directly.
  2. Do you have a USB card reader? That will mount your card as a drive in Explorer.
share|improve this answer
    
I connect directly to the laptop. I don't have a USB card reader. –  daremon Oct 13 '09 at 18:26
add comment

You need to find the Communication Settings in the menu. It's probably set to PTP, so set it to MTP. I don't have that camera, but I've used several different Canons and that's what the setting is usually called. The manual for your camera doesn't mention more specifically where the setting is located, but it does list it.

Also, you should definitely get a card reader. They're faster than using the camera and doesn't use up your camera battery to get the photos off of it.

share|improve this answer
    
I thought the same, and had to pinch the wife's to check, and it didn't have it from the main menu :/ –  Rowland Shaw Oct 13 '09 at 19:59
    
I don't have my camera to check (a friend has it overseas right now) but the option is in there somewhere, the manual even refers to it. Possibly take the camera out of full-auto mode if that's what it's set to, which limits some of the menu options. –  emgee Oct 13 '09 at 20:37
    
The manual does list the option, but I could not find it on the menu. I searched every option in every possible camera mode I think... –  daremon Oct 14 '09 at 7:09
    
I checked and there's no firmware update for your camera, so at this point I can't think of anything other then get a card reader... –  emgee Oct 14 '09 at 16:10
add comment

USB Mass storage mode allows you to interface the device memory over its USB interface
as if it were a pen drive.

However, usually the actual memory module is detachable from the device and can be plugged in to the PC USB port with the correct USB adapter. In fact, most machines these days come with a multi-port 'card reader' to let you easily plug in this module.

The Canon IXUS 990 IS seems to use SD/SDHC cards.
You should be able to get a suitable USB adapter for 'mounting' the memory like a USB Pen Drive and transferring data at USB 2.0 speeds.

Many times (typically with older models) the USB port is quite slow (USB 1.1 maybe).
Transferring directly from the memory card would work much faster.
Your model probably has a USB 2.0 interface.


Here is a reference to the User Manual for your camera (you should have a paper copy).

  1. p16 shows how to insert and remove the memory card

  2. pp38-39 show how the memory card can be plugged into your PC with a card-reader
    (like I describe above).
    p42 shows the memory card and battery cover as item 12.

  3. p158 describes the memory cards supported: SD, SDHC, MMC, MMCplus, HC MMCplus
    It also describes the interface to be Hi Speed which implies USB 2.0

sadly no note about PTP or Mass Transfer mode selection -- leaves me in doubt

share|improve this answer
add comment

Try using an external transfer agent.

For instance: Richcopy

share|improve this answer
add comment

You can try FileSaver. Advantage of this program is that it copies data in stages. Each stage will only copy parts that haven't succeeded in previous one.

Most of file copiers will copy same file each time from start, they will stop at same place each time.

P.S. Since KB article states that there is hot-fix available, you can just call Microsoft support, give them KB article number, and they will give you hot-fix. This would probably be least painful solution.

share|improve this answer
add comment

You could try using Teracopy: Teracopy

TeraCopy is designed to copy and move files at the maximum possible speed. It skips bad files during the copying process, and then displays them at the end of the transfer so that you can see which ones need attention. TeraCopy can automatically check the copied files for errors by calculating their CRC checksum values. It also provides a lot more information about the files being copied than its Windows counterpart. TeraCopy integrates with Windows Explorer's right-click menu and can be set as the default copy handler.

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.